Page MenuHome

Mac standard "command-period" keyboard shortcut not supported
Closed, InvalidPublic

Description

System Information
Operating system: MacOS High Sierra 10.13.6 (17G5019)
Graphics card: Intel Iris Graphics 6100 (Macbook onboard)

Blender Version
Tested 2.8.0 and 2.8.1 (build September 08, 23:31:34 - f3a4f12ac090).

Short description of error
There is a standard Macintosh shortcut in dialog boxes, "command-period" is always the shortcut for "cancel" or "abort". This has been present since Mac OS 7 in the 90s at least and so it can be very ingrained in a mac user's reflexes. Blender implements its own dialog boxes and does not recognize command-period.

Exact steps for others to reproduce the error
I open Blender 2.8.1. I create a new file. I go to File->Save As. Once the Save As box is visible, I hit cmd-period. Nothing happens.

I open Blender 2.8.1. I create a new file. I go to File->Open. A box pops up asking, save changes to Untitled before closing? I hit cmd-period. Nothing happens. (This box has a shortcut of "press C to cancel", but that is not mac standard.)

Compare what happens in a normal OS X application: Open TextEdit.app, create a new file, type three letters, and try to close the window. A dialog sheet will appear and ask, Do you wish to keep this new document?. If you hit command-period at this moment it will react as if you clicked "cancel".

Impact
This is a "paper cut" but if Blender is trying to fix UI "paper cuts" I think this would be a good one to look at. It would make Blender feel more like a OS X application. Again: This is a Mac OS X thing only.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

This sounds more like a feature request than a bug.
It is a nice suggestion (raising awareness to @William Reynish (billreynish) and @Julian Eisel (Severin)...), but it is not a bug.

Will close this, note you can always approach other channels for requests and feedback:
https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests