Page MenuHome

Text file easily overwritten
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.15

Blender Version
Broken: version: 2.81 (sub 5), branch: master, commit date: 2019-09-03 14:53, hash: rB4c14a7484cf1

Short description of error
OK, I noticed this yesterday when I easily overwritten a backup of a addon.

Loaded text file and path

Do "Save As" and the path gets changed. This is why files get overwritten ,but the file is not even loaded inside Blender.

Exact steps for others to reproduce the error

  1. Save text (.1 in pic)
  2. Save text again with new name using "Save As"
  3. Make changes to original text inside Blender
  4. Click "Save" to save changes to original (.2 in pic)
  5. Changes got to saved to the last save instead of original (.3 in pic)

Details

Type
Bug

Event Timeline

Dalai Felinto (dfelinto) closed this task as Invalid.
Dalai Felinto (dfelinto) claimed this task.

Thanks for the report. It seems that you are "mistaking" the concepts of Save As and Save Copy. The tool is working as intended. What you expect to happen would be "Save Copy".