Page MenuHome

alt + mouse click for editing parameter of multiple selected object not work.
Closed, DuplicatePublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: AMD Radeon HD 7600M Series ATI Technologies Inc. 4.5.13422 Core Profile Context 0

Blender Version
Broken: version: 2.81 (sub 12), branch: master, commit date: 2019-09-30 22:00, hash: rB60a827a2a991
Worked: (optional)

Short description of error
With the graphics tablet i find it essential to activate emulate 3 button mouse.
The problem is that with this mode it is impossible to edit multiple objects simultaneously.

alt + mouse click

for move and editing parameter of multiple selected object not work.

Exact steps for others to reproduce the error

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Archived.Wed, Oct 2, 1:49 PM
Philipp Oeser (lichtwerk) claimed this task.

This sounds more or less logical?
Alt + LMB is just converted to MMB in wm_eventemulation in the case of emulate 3 button mouse.
Not sure if an exception for being over a button is really feasible?

In any case, this sounds more like a feature request that could go into other channels...
https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests
https://wiki.blender.org/wiki/Reference/Not_a_bug

Will close ( unless there are objections? @Campbell Barton (campbellbarton), @Julian Eisel (Severin), @William Reynish (billreynish) )

@Philipp Oeser (lichtwerk) in my opinion I don't think it's a feature request, it's just that the "grab-scroll-window" function that is activated with "alt " in emulate 3 button mouse mode, goes into conflict when we simply have to modify some parameters with alt +click (in this case of many objects edit)

therefore in some way "the grab-drag area with alt + click", in the elements of the parameters change should be disabled when the mouse cursor is on the elements

@noki paike (amonpaike):
grab-drag area = MMB
ALT+LMB gets converted to MMB early on (see above).

So if [at all] I think we would need to circumvent the conversion in wm_eventemulation in case we are over an appropriate button.
But like I said, not sure if is feasible and would still think it this is not a bug.
I mean you are loosing tons of ALT+LMB functionality already by emulate 3 button mouse (e.g. loop select, etc..), would all these be bugs?
In my opinion, user should expect that ALT+LMB functionality will be lost by emulate 3 button mouse (or has to be mapped elsewhere manually...).

But others can chime in here, thats just my opinion.

for me it's the same .. as long as I can use these functions ..
how could I alternatively map the "multi object editing" function ...
is a keymap that can be changed?
I didn't think it was possible ...
in any case, wouldn't it be useful to remap this function for all users who use "emulate 3 button mouse"? with another shortcut agreed upon .. (at the moment for these users it is still "broken")

it would be an easy thing to correct.

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.

You are right, I think ALT+LMB for "multi object editing" cannot be remapped.
Not convinced still (about this being a bug), but I'll let others decide then (suspects are already CCed here...)

@Campbell Barton (campbellbarton) Since this problem cannot be solved on windows (please look at the video I have attached to understand what I am referring to in particular) because the oskey is not available on windows, it would not be solvable by activating the "mouse wheel" on the number field and slider value overlay to modify the parameters ... so you could easily add the "alt + click" exception in the case of editing several objects with emulate middle button. .. or maybe it would already be activated..