Page MenuHome

commit 3a08153d7a8 introduces X11 error
Closed, ResolvedPublic

Description

I've recently rebuilt blender and it doesn't start.
So I've gone backward through commit history until this:

[Bf-blender-cvs] [3a08153d7a8] master: DRW: Refactor to support draw call batching

which prevents blender to start.

when run in console, blender gives this error message:
Received X11 Error:

error code:   8
request code: 154
minor code:   34
error text:   BadMatch (invalid parameter attributes)

Received X11 Error:

error code:   2
request code: 154
minor code:   34
error text:   BadValue (integer parameter out of range for operation)

System Information
Operating system: Ubuntu 19.04
Graphics card: nvidia geforce gt 240

glxinfo output:
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 3.3.0 NVIDIA 340.107
OpenGL core profile shading language version string: 3.30 NVIDIA via Cg compiler
OpenGL version string: 3.3.0 NVIDIA 340.107
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
OpenGL ES profile version string: OpenGL ES 2.0 NVIDIA 340.107 340.107
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.00

Blender Version
Broken: from commit 3a08153d7a8 on
Worked: until commit 16d59192064 functions: copy color to new particles in trails node

thanks

Details

Type
Bug

Event Timeline

just out of curiosity, try to see if blender starts with

blender  --debug-gpu-force-workarounds
sam (trix) added a comment.EditedOct 2 2019, 6:26 PM

blender --debug-gpu-force-workarounds doesn't work,
but the issue is now solved by [f8f28dc7841] master: Workaround for NVidia broken driver

thanks!

Brecht Van Lommel (brecht) closed this task as Resolved.Oct 2 2019, 6:40 PM
Brecht Van Lommel (brecht) claimed this task.