Page MenuHome

A.N.T. Landscape addon options menu crashing
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Home
Graphics card: GTX 1070 Sc TI

Blender Version
Broken: Blender 2.80.75

Short description of error
Whenever you create a new landscape using the addon, the context menu "Another Noise Tool" appears. However, whenever you attempt to do anything with it, the menu closes (crashes?) immediately, leaving you with an unedited landscape.

Exact steps for others to reproduce the error
Just startup blender, make sure to enable the A.N.T. Landscape addon, and try and create a new landscape.

Details

Type
Bug

Event Timeline

hi, I've tested this in blender 2.81 alpha and there's no issue here. I create the mesh then test all the settings and presets. If you click off the menu it will close. To Edit the mesh again you need to Use the Sidebar Create Tab Landscape panels, which give you options to recreate or edit. If you prefer the Operator panel in the 3d view, you can delete the landscape mesh and Add > Mesh > Landscape to add a new landscape and it should have the same settings. (tested Working) Saving your landscape as a preset also works.
Does this help or can you tell more about your error? Is there an error printed in the console?

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Thu, Oct 10, 10:24 AM

Also having no issues here.
We would need the information @Brendon Murphy (meta-androcto) asked for to proceed.
Please also check a fresh build from https://builder.blender.org/download/
Please also try with File → Defaults → Load Factory Settings and only enable ANT (nothing else) to see if you still can reproduce this issue.

hi, I've tested this in blender 2.81 alpha and there's no issue here. I create the mesh then test all the settings and presets. If you click off the menu it will close. To Edit the mesh again you need to Use the Sidebar Create Tab Landscape panels, which give you options to recreate or edit. If you prefer the Operator panel in the 3d view, you can delete the landscape mesh and Add > Mesh > Landscape to add a new landscape and it should have the same settings. (tested Working) Saving your landscape as a preset also works.
Does this help or can you tell more about your error? Is there an error printed in the console?

I do not see anything in the console. The context menu is entirely dimmed, or "grayed-out." However, today, after resetting Blender to factory settings it was working again. I have no idea what caused the issue, but it is closed.