Page MenuHome

Windows update
Open, Needs Triage by DeveloperPublic

Description

After Windows update 11oct. 2019, several addon will not start. Import Autocad DX format (dxf) will not start. Allso other import/export format do not work,: stl fbx and others

Operating system: Windows 10 pro
Graphics card: Nvidia Geforce GTX1080
16GB RAM
I7 3930cpu 3.2GHz

2.8 release candidate 2

allso v 2.81 Beta , 60d02b336eaf

Import/export are limted to just collada (dae) and Alembic (abc)

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 14 2019, 10:02 AM

What do you mean with "will not start"? Is there some error message?

no erroror message. Under preferences, I have uncheked several import format, like dxf, stl, fbx and others. They are still unchecked, but are not available. The only import or export format are now abc or dae. This happends after update of Windows. I have uninstalled the updates but this did not help

Please make a screenshot that shows where something is missing.

Hm, I cannot reproduce the issue. Have you checked if there is an error in the terminal? You can open it via the Window menu in Blender.

See below

If I uninstall Blender, and reinstall, what is the best way to preserve all preferance to add-on and import format ?

Read prefs: C:\Users\Odd\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead
found bundled python: F:\blender 28 install\blender-2.80rc2-windows64\2.80\python
archipack: ready
module changed on disk: 'F:\\blender 28 install\\blender-2.80rc2-windows64\\2.80\\scripts\\addons\\object_print3d_utils\\init__.py' reloading...
mb_lab updater verbose is enabled
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_install_popup'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_install_popup'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_check_now'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_check_now'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_update_now'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_update_now'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_update_target'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_update_target'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_install_manually'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_install_manually'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_updated_successful'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_updated_successful'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_restore_backup'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_restore_backup'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_ignore'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_ignore'>
cls BA: <class 'MB-Lab-master.addon_updater_ops.addon_updater_end_background'>
cls: <class 'MB-Lab-master.addon_updater_ops.addon_updater_end_background'>
mb_lab Updater: Read in json settings from file
Warning: class FSPY_BLENDER_OT_import_project contains a property which should be an annotation!
C:\Users\Odd\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\fspy_blender\
init__.py:50

assign as a type annotation: FSPY_BLENDER_OT_import_project.filter_glob
assign as a type annotation: FSPY_BLENDER_OT_import_project.update_existing_camera
assign as a type annotation: FSPY_BLENDER_OT_import_project.import_background_image

When open this file you will see the problem. Look at import/export and preferences

I have maybe solved the problem. I started an old file with drag&drop on the exe-file, and all came back. I saved the file as startup file, open again a new file, deleted all, and saved the file as startup-file. The file are not working and still have the same problem. See last comment, where the file was uploaded

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Oct 16 2019, 4:54 PM