Page MenuHome

Knife tool stopped showing preview vertex and does not cut. (2.82)
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce 920M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.17

Blender Version
Broken: version: 2.82 (sub 0), branch: master, commit date: 2019-10-15 09:30, hash: rB3db7f145df21
Worked: (optional)

Short description of error
In perspective view knife tool not working and not showing preview pixel/line.


In side view everything works fine.

Exact steps for others to reproduce the error
Select object.
Make sure you are in perspective view mode.
Press TAB.
Press K or select Knife Tool.


By the way I've deleted everything from project. One object with 10 verts is left. I don't know why blend file is 35 mb.

Details

Type
Bug

Event Timeline

You've set the far clipping plane too far, resulting in very poor depth precision, resulting in knife not being able to project properly. Open the N key sidebar and lower the Clip End value in View to something like 1000 or even less.

As to why the file is 35Mb: Blender does not delete orphaned data immediately, only when you reopen the fie. You can see it if you switch the outliner to show Orphan Data. You deleted the objects, which made their meshes orphaned (0 users). On next reload, i.e. loading the file attached to this report, the meshes are removed, which then makes all the materials orphaned. This is what you will see in Orphan Data in this file, it'll show +99 Materials, though it would appear there's actually almost 1800! Anyway, if you save this file again and reload it, materials will be removed, but images are only orphaned. Finally, saving and reloading again gets rid of the images as well.

I can confirm what @Stanislav Blinov (radcapricorn) said. I'm not sure if this should be considered a bug or whether this should be some warning. Will leave the decision to @Campbell Barton (campbellbarton).

Btw, instead of saving and reloading you can also click on Purge in the orphan view in the outliner.

@Jacques Lucke (JacquesLucke) a warning could be a good thing for UX. People seem to run into this on a regular basis.

@Stanislav Blinov (radcapricorn) Ok thanks. I was confused because it was working well. I've changed clipping plane few days ago and it was fine.

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Nov 6, 4:52 PM

I don't think there is a good way to show a warning without it also being annoying in cases where it's intentional. Either way, seems outside the scope of the bug tracker.