Page MenuHome

Pause preview button doesn't change from pause symbol to play symbol only highlights blue.
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 980 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.60

Blender Version
Broken: version: 2.81 (sub 15), branch: master, commit date: 2019-10-18 14:41, hash: rB970d7ed860f1
Worked: (optional)

Short description of error

Spent an hour wondering why viewport for render was not working properly for cycles (no rendering). This was due to the pause button being unknowingly activated. With it hiding in the top right corner and not changing to a play button it was hard to realize this was the issue. I suggest having it change to a play button to make it just a little more apparent to new users like myself.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]
NA happens with one button click

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Archived.Oct 21 2019, 2:05 PM
Philipp Oeser (lichtwerk) claimed this task.

Could be nicer, agree, not a real bug though (btw., you should also see a text "Rendering Paused" in the top left corner if you have Text Info overlay showing...).

1
2
3diff --git a/intern/cycles/blender/addon/ui.py b/intern/cycles/blender/addon/ui.py
4index b2624b2aa81..4ff154d4bcd 100644
5--- a/intern/cycles/blender/addon/ui.py
6+++ b/intern/cycles/blender/addon/ui.py
7@@ -2166,7 +2166,7 @@ def draw_pause(self, context):
8
9 if view.shading.type == 'RENDERED':
10 cscene = scene.cycles
11- layout.prop(cscene, "preview_pause", icon='PAUSE', text="")
12+ layout.prop(cscene, "preview_pause", icon='PLAY' if cscene.preview_pause else 'PAUSE', text="")
13
14
15 def get_panels():

@William Reynish (billreynish): Does this catch your eye? Do you think this should go in?

Will close this anyways, since this is not really a bug.
https://wiki.blender.org/wiki/Reference/Not_a_bug