Page MenuHome

Multiple Object Editing Pose Mode Doesn't Properly Update NLA Editor
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows 7 x64
Graphics card: NVIDIA GeForce GTX 580

Blender Version
Broken: 2.80
Worked: 2.79

Short description of error
When animating with multiple rigs in Pose Mode, switching the active object (by selecting a Pose Bone belonging to a different rig in the 3D View) while NLA Tweak Mode is active doesn't properly switch the animation data in the Action and NLA Editors. Upon switching objects, the Action and NLA Editors remain pointed at the former object. This makes it easy to lose work, as any posing of the newly active object won't be keyframed by auto-keyframe, and will be lost when changing the current Scene frame.

In 2.7, with 'Show Only Selected' set in the NLA Editor, it was possible to have multiple Armatures in Tweak Mode, allowing the user to switch between objects without having to toggle Tweak Mode. With Multiple Object Editing, it should be possible to activate Tweak Mode on multiple objects simultaneously without having to exit and reenter Tweak Mode whenever switching the active object.

Exact steps for others to reproduce the error
Enter Pose Mode with multiple Armatures, activate auto-keyframe, animate both Armatures and Push Down the Actions into NLA Strips, activate Tweak Mode on one strip and select a Pose Bone from the other armature in the 3D View, transform the bone and it won't insert a keyframe.
Also, activate Tweak Mode and select an NLA Strip belonging to the other Armature. Tweak Mode exits as if the user selected a strip belonging to the same Armature, when in 2.7 it would remain active on each object individually.

Details

Type
Bug

Event Timeline

Bun ny (bunny) added a project: Animation.