Page MenuHome

Particle collisions aren't simulated before frame zero for negative frame simulations
Confirmed, NormalPublicKNOWN ISSUE

Description

Blender Version
Broken: 2.79, 2.81
Worked: (optional)

Short description of error
Making particles simulation start from negative frames don't allow for those particles to have collisions with meshes. Unless I set the initial frame to be negative.

Exact steps for others to reproduce the error

Open the file and look at the already baked simulation. The first particles went through while the later ones collide perfectly. You can also rebake the cache and see the same result

Known workaround
Change initial frame to match the first simulated frame before baking the simulation.

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Jan 15 2020, 5:53 PM

I re-baked cache and didn't see the same result

Is this still an issue with latest build? https://builder.blender.org/download/

Richard Antalik (ISS) closed this task as Archived.Jan 23 2020, 1:51 AM
Richard Antalik (ISS) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to close the report.

Tried it on 81b7f8efaf7a from Jan20th and it still happens after rebaking

Philipp Oeser (lichtwerk) reopened this task as Needs Triage.Jan 23 2020, 10:54 AM
Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from Developers.Jan 23 2020, 11:06 AM

I still see no issue here...

Sybren A. Stüvel (sybren) changed the task status from Needs Information from Developers to Needs Information from User.Jan 23 2020, 2:47 PM

I also can't reproduce here with current 2.82 branch (rBfb0136f908652a0fef). I did enable User Preferences → Animation → Negative Frames, as working with negative frames makes no sense otherwise.

@SecuoyaEx (SecuoyaEx) can you make a video (or series of screenshots) that show what you're doing, with the latest nightly build of Blender?

Dalai Felinto (dfelinto) changed the task status from Needs Information from User to Confirmed.Feb 6 2020, 3:35 PM
Dalai Felinto (dfelinto) changed the subtype of this task from "Report" to "Known Issue".

I can reproduce the issue. It happens if you try to bake and your initial frame is not the initial frame of the simulation (-100 in this case).
The same issue happens in 2.79.

Simulations with negative numbers initial frames are not working well, unless you deliberately set the start frame accordingly.