Page MenuHome

Select All in Multi Object Pose Mode Doesn't Respect Hide Select
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows 7 x64
Graphics card: NVIDIA GeForce GTX 580

Blender Version
Broken: 2.80

Short description of error
With multiple objects in Pose Mode, Select All selects bones belonging to objects which have the Hide Select flag set.

Exact steps for others to reproduce the error
Create two armatures, put both into Pose Mode, set Hide Select on one of the armatures via the Outliner. Attempt to select a single bone in the hidden armature with a mouse click (unable to select, as expected), use 'A' to Select All (bones in the hidden Armature are selected).

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Jan 2 2020, 9:53 AM

Can confirm.

For multi-object editing this is also the case for other selection tools [box select tool and click picking respect the object hide_select, circle & lasso dont...]
multi-object editing this is also the case for other selection operators [select invert...]
(This is not only the case for multi-object editing though, this already fails with a single armature. if it was already slelected before)
2.79 also has the same issue.

Individual bones hide_select is respected, but the Armature object's isnt... (it is debatable whether this should be done, but it should be consistent across all selection operators -- viewport select pick and the others... see above)

Sybren A. Stüvel (sybren) changed the subtype of this task from "Report" to "Bug".

This looks like a bug to me. Assigning to @Campbell Barton (campbellbarton) as he implemented multi-object editing.