Page MenuHome

Fluid sim , physics settings desappeared !
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: Quadro P2000/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 391.33

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Once i set a fluid sim , baked it , shutted off the Pc , and turned on again (it happened also after closing the file and re opened that) , i open the file , the sim works fine but there is no way to change settings in the physics panel.

it seams the issue happens randomly
I ve got the same issue 3 times starting the same project from zero in different files of course

Event Timeline

Germano Cavalcante (mano-wii) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

When opening the file I see this error message that is probably related:
ERROR (bke.modifier): C:\Germano\Dev\BlenderDev\blender\source\blender\blenkernel\intern\modifier.c:410 modifier_setError: Modifier requires original data, bad stack position

@Bastien Montagne (mont29), this one is for you?

Bastien Montagne (mont29) raised the priority of this task from Confirmed, Medium to Needs Triage by Developer.

We do not handle user support on this tracker, only bug reports. User forums like blenderartists.org or blender.stackexchange.com and our devtalk should be used for that matter.

Just go to the modifiers stack and look at things a bit? Like the message displayed by the fluidsim place-holder there? Or indeed actually read error messages in the console…

User Interface project might consider reporting that error message in the physics properties too though, would not hurt and would avoid that kind of confusion?

@Germano Cavalcante (mano-wii) that kind of report should really never reach the dev level… Please try to understand a bit the issue, especially before assigning a report to someone. CC @Dalai Felinto (dfelinto) and @Nathan Letwory (jesterking) .

Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

So issue is actually elsewhere: for some reasons (???) physics settings are also restrained to some 'compatible' render engine (why?), and workbench (which is active engine in that file) is not in the list (why???).

That is not my area at all, it’s either the User Interface or Physics team to solve this...

Render engines controlling visibility of physics settings is a left over from the game engine, which had its own physics. Game engine add-ons could still do something similar, so we might as well keep it as is.