Page MenuHome

Alt-H only unhides collections while in outliner, not 3D View
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
After using Ctrl-H or 1,2,3 (etc) to isolate a collection, Alt-H will only unhide objects from within that collection unless the cursor is hovering over the outliner.

Exact steps for others to reproduce the error
Have objects in several collections. Use Ctrl-H or press 1,2,3 (etc) to isolate to 1. From fullscreen Ctrl-H there is no way to unhide these collections.
Alt-H will only unhide all collections if the cursor is hovering over the outliner.
If you have 3 collections, and press 1, you will hide everything from collections 2 and 3. In fullscreen you must now press Shift-2 and Shift-3 to unhide these collections (if there are hidden objects in a collection you can unhide them using Alt-H provided the collection itself is already unhidden).
This behavior is actually GOOD for some, based on what I've read. The frustration is that there is no hotkey to unhide collections from within the 3D Viewport.
Ideal fix: Leave the behavior as is so that Alt-H only works on selected collections (to allow for a more selective unhide). Add a DISTINCT hotkey to "unhide all collections".

Event Timeline

I believe this is by design.
Alt + H does not unhide collections (but only objects).
When the cursor is inside the outliner the context is different, so the behavior may be different (unhiding collections for example).

@Dalai Felinto (dfelinto), any thoughts on that?

Philipp Oeser (lichtwerk) claimed this task.

Thx for the report!

Agree this could be improved [operator plus shortcut to reveal hidden collections from the 3DView could/should be added at some point]

But since we already have Ctrl+H and also Sidebar > View tab > Collections panel [where you can click drag across multiple collections for speed], and since the code itself is working as intended, I'd have to say this looks more like a feature request than a bug. Having feature requests is totally fine [it is one of blenders strengths to have an active community like this - driving with constructive ideas...] but please use other channels for this: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests
For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

So for above reasons, will close this report, thx again anyways!