Page MenuHome

Blenderkit doesn't work in 2.81
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-10-31 19:29, hash: rB78ad368d12d8
Worked: (optional)

Addon Information
Name: BlenderKit Asset Library (1, 0, 28)
Author: Vilem Duha, Petr Dlouhy

Short description of error
Doesnt work in 2.81. Objects wont spawn in the scene at all.

Exact steps for others to reproduce the error
Just try spawning object in the scene

Details

Type
Bug

Event Timeline

Neith Zaldrizes (zaldrizes) renamed this task from Doesn't work in 2.81 to Blenderkit doesn't work in 2.81.Sat, Nov 2, 1:02 AM
Neith Zaldrizes (zaldrizes) created this task.

Ok SO. i figured it out. The issue is only when you change a default global path for assets. the file browser appends a slash at the end of a new path but blenderkit cant handle this so it ends up having double slash which makes the path incorrect. Its definitely a bug and needs fixing. however small it is very nasty .

@Vilem Duha (pildanovak),

Ok SO. i figured it out. The issue is only when you change a default global path for assets. the file browser appends a slash at the end of a new path but blenderkit cant handle this so it ends up having double slash which makes the path incorrect. Its definitely a bug and needs fixing. however small it is very nasty .

If this is the case, it seems to be a simple fix.
@Vilem Duha (pildanovak), could you take a look?

Vilem Duha (pildanovak) closed this task as Resolved.Sun, Nov 10, 10:46 PM

Fixed this with commit 8eead22f9aec631068919f2f17a620d5336e4105 in the 2.81 release branch/