Page MenuHome

Can't click-drag visibility when local collections enabled
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-4.15.0-45-generic-x86_64-with-debian-buster-sid 64 Bits

Blender Version
Broken: version: 2.82 (sub 1), branch: master, commit date: 2019-11-05 14:39, hash: rBf5e98a0fa7db

Short description of error
When "Local Collections" is enabled, toggling visibility of multiple collections at once in sidebar doesn't work.

Exact steps for others to reproduce the error

  • Create multiple collections (they don't need contents or anything)
  • Open sidebar (N) -> View tab -> Collections panel
  • Try holding left-click on an eye icon, then start dragging over the others in the list - they should all toggle, like expected
  • Enable "Local Collections" checkbox and try the same again - only one will toggle once you release the mouse button

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Low.Thu, Nov 7, 10:03 AM

Confirmed, checking...

Philipp Oeser (lichtwerk) closed this task as Archived.Thu, Nov 7, 10:39 AM
Philipp Oeser (lichtwerk) claimed this task.

This turns out not to be a real bug.
For the end user, this might be unexpected, but this can hardly be avoided.
Due to the implementation of Local Collections (see rB92736a7b7592), there is some more to be done for Local Collections then just set the COLLECTION_RESTRICT_VIEWPORT flag.
[e.g in this case, we also depend on the View3D, this cannot be done generally for any collection without context through RNA]

So

  • if Local Collections is OFF, hide_viewport is used with the eye icon [that is a property, can be dragged over]
  • if Local Collections is ON, hide_collection is used with the eye icon [that is an operator, can not be dragged over]

So while this is not impossible to be improved upon, will archive for now...
For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug