Page MenuHome

EEVEE: long background render times create sluggish viewport
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 560X OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.11.20

Blender Version
Broken: version: 2.82 (sub 1), branch: master, commit date: 2019-11-04 20:01, hash: rBef7fd50f8a93
Worked: (optional)

Short description of error
The EEVEE background render times at (250ms) create a sluggish viewport. I strippeed away as much as possible, so deleting a material / modifier or hiding an element will restore the background render times to less then 10ms. Also moving a mesh (Part1 or Part2) out of the "Eyes" collection the viewport speed is ok again. But very oddly the order of adding any of these meshes back to the "Eyes collection" - so first Part1, then Part2 vs. first Part2, then Part1) makes the viewport behave correctly or very sluggish.

Exact steps for others to reproduce the error

  1. open the file
  2. rotate in the viewport

Event Timeline

Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Needs Information from User.Jan 9 2020, 4:39 PM

When I open this file, the viewport performance seems to be just fine. Has this been fixed?
Can you show the issue in a screen recording somehow?

I think this is a OSX specific bug. Using Instruments.app I can see the function SCCompileShader using all the cpu resources. I tried to track it down to a specific setup or shader, but I was not yet able to get to the bottom of it. The problem could be the same as to point 5 on https://blog.jimmymakesstuff.com/2017/02/a-very-peculiar-osx-opengl-sdl2-bug.html . Maybe someone can give me a hint how to get to the bottom of it.

I can still reproduce it with:
Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-01-09 16:07, hash: rB9b920938bbca

Here you can see the 100% cpu usage in Instruments.app:

Jean First (robbott) changed the task status from Needs Information from User to Needs Triage.Jan 10 2020, 12:28 PM

On my system the pinanta_bug.blend file exhibits the viewport lag, but if you switch the material of the Body object (Pinata_KM_20191105) Blend Mode: Alpha Blend, the lag disappears. Any of the other blend modes exhibit the lag. You can also fix the lag by setting the metallic property to .99 or less.

MacBook Pro/AMD Radeon Pro 5500M 8 GB/Catalina 10.15.2/Blender 2.82.6

Campbell Barton (campbellbarton) changed the task status from Needs Triage to Confirmed.Feb 12 2020, 7:53 AM
Campbell Barton (campbellbarton) changed the task status from Confirmed to Needs Triage.
Bastien Montagne (mont29) changed the task status from Needs Triage to Needs Information from Developers.May 27 2020, 6:25 PM
Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Bug".
Germano Cavalcante (mano-wii) changed the task status from Needs Information from Developers to Needs Information from User.Jun 4 2020, 2:53 PM

Some improvements have been made in this area (such as rB96eab0875597).
Can anyone confirm if this problem was fixed in the latest builds?

Jean First (robbott) closed this task as Resolved.Jun 5 2020, 4:03 AM
Jean First (robbott) claimed this task.

Bug seems fixed. Tested with rBc7329da14b224f93e93f54c24d42a05dda18ce19 . Thanks a lot.