Page MenuHome

GPencil: Parented Layer to Bone rotation not as expected.
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.3.0-23-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-10-28 18:34, hash: rB7c1fbe24ca33
Worked: (optional)

Short description of error
Relations/parenting in Grease Pencil aren't working as expected for layers.

Exact steps for others to reproduce the error

  • Open Blender
  • Choose 2D animation for the new file
  • Enter object mode/exit draw mode
  • Delete Grease Pencil object
  • Add Grease Pencil Monkey head
  • Add armature (single bone)
  • In Object Data Properties, Layers, Relations, parent each layer to the bone of the armature.
  • Select the Monkey object in the viewport and move it (attached example was in the z axis).
  • Select the armature
  • Enter Pose mode
  • Rotate the bone

Rather than rotating from the bone pivot point, the Monkey head is rotating from the pivot point where the bone used to be before the move in the z-axis.

I've tried this in 2.8, 2.81, 2.82 and the Grease Pencil Object branch (downloaded today - Hash 56bdf8f9be6c), all with the same result.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) renamed this task from Grease Pencil rotation not as expected. to GPencil: Parented Layer to Bone rotation not as expected..Tue, Dec 3, 4:25 PM
Antonio Vazquez (antoniov) claimed this task.
Antonio Vazquez (antoniov) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.
Antonio Vazquez (antoniov) lowered the priority of this task from Confirmed, Medium to Confirmed, Low.Tue, Dec 3, 4:45 PM

I have been looking at the code and the problem here is the layer parent is a "sublevel" of the object parent, so this is always inside object space, so when you rotate the bone, you are rotating using the object local space. Actually, to make the code supports this rotation around the actual positions, instead to use, the local object space would require a deep change in design and it's out of scope at this moment because you have an alternative way to do it.

We can consider this as a non supported feature and we could add in future ToDo list, but actually we cannot consider it as a bug.

@Germano Cavalcante (mano-wii) How must we proceed with this task? Archive as "feature request"?

If we archive it, we will open a new task when we decide to implement this feature.

If you think that's the best way to go, it sounds good to me :)

Just to clarify, is the alternative way you're thinking of to split the layers up into individual GP objects and parent at an object level to the bone? That's the way I worked around this issue, thought it might be useful to others coming across this issue to know too.

(...)
@Germano Cavalcante (mano-wii) How must we proceed with this task? Archive as "feature request"?
If we archive it, we will open a new task when we decide to implement this feature.

The report can be closed as a known limitation and a design task created.
Or this report can be edited to become the design task.
(I don't think there is a strict rule for this case.).

Antonio Vazquez (antoniov) closed this task as Archived.Tue, Dec 3, 5:16 PM

@stephen thomas (stephenthomas0) You can split in several objects or put the bone in the place of the GPencil drawing to make it more "usable". Then, as the bone is in the right place, when you rotate, strokes will rotate too.

If you need rotate more things with one bone, maybe is better you make a rig with the corresponding constraints and/or parenting puting each child bone in the same place of the stroke...and finally parent the GP layers to each bone.

We archive as known limitation and we will open a task in the future.