Page MenuHome

Changing manipulators is broken in the pie menu on 2.81
Open, Confirmed, LowPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 416.34

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3
Worked: (optional)

Addon Information
Name: 3D Viewport Pie Menus (1, 2, 9)
Author: meta-androcto

Short description of error
The changing of manipulators seem to be broken on 2.81 with the pie menu. When I try to change between manipulators using Alt - Space, it doesn't do anything.

Exact steps for others to reproduce the error
First I select an object and with the Alt+Space key shortcut I open the pie menu with manipulators. Then I try to select one from the selection which is not currently used, however the manipulator does not switch to the chosen manipulator and stays unaffected.

Details

Type
Bug

Event Timeline

Works here. Make sure you're not using an active tool (move, rotate, scale). These take precedence over the old manipulators.

Brendon Murphy (meta-androcto) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mon, Nov 25, 11:24 AM

hi, I'm unable to reproduce this error. I'm using Blender 2.81 release and have tested your report and everything appears working. I did notice that the "w manipulators" operator pop up menu has the "Extend" option. It's needed to hold shift when this is active to show multiple manipulators at once. Is there anything you may have done? Any settings you have made that may cause the addon to fail? Any conflicting other addons hotkeys?
Could you try with a default "Factory Settings" and see if that works?

Oh, Stanislav is right, I was having an active tool selected and did not know that the pie menu is using the old manipulators. So it kind of works, although it is really confusing.

Brendon Murphy (meta-androcto) lowered the priority of this task from Needs Information from User to Confirmed, Low.Mon, Nov 25, 11:41 PM

ahh, that makes sense, I'll try to have a look soon and see if I can fix this.


Just a quick follow up, we have the same behavior when using the viewport gizmo's. The active tools seems to over-ride them.
Select an active tool Move/Rotate/scale and the viewport gizmo's have no effect. This is the same as in the manipulator pie's behavior.
It is rather confusing yes.