Page MenuHome

texture coordinate "from instancer" option does not work for verts
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.20

Blender Versions
Broken: version: 2.82 (sub 3), branch: master, commit date: 2019-11-30 17:33, hash: rBf1ac64921b49
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3
and probably more...

Short description of error
texture coordinate "from instancer" option does not work when instancer is set to verts. it works when set to faces
here is a simple blend file:
http://pasteall.org/blend/index.php?id=52640

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Mon, Dec 2, 3:50 PM

Not sure I am reading this wrong:
https://docs.blender.org/manual/en/dev/render/shader_nodes/input/texture_coordinate.html

From Instancer only works with the UV output when the object is instanced, either from particles or from faces.

Cannot really get it to work with Generated coords either though...

Might be a limitation, this is only working for faces?

Note: we had this for faces in viewport rendering T60646: Texture Coordinate node, From Instancer option do not work as expected in 2.8 which was fixed.

Maybe @Sergey Sharybin (sergey) can put the nail in the coffin?

yes it only works with faces.
it works for particles that are emitted from faces as well, but not when they are emitted from verts.

Sergey Sharybin (sergey) closed this task as Archived.Fri, Dec 6, 8:33 AM
Sergey Sharybin (sergey) claimed this task.

Quite sure it is the same as in all previous versions of Blender.

The reason why this is happening is because texture coordinate is stored per-face-corner (called loop in Blender) and a vertex can be adjacent to a multiple face-corners with different texture coordinates.

There might be a way to find an artist predictable mapping, but it's something what hasn't been done yet.

So thanks for the report, but it's just a known limitation.

aombk (aombk) added a comment.EditedFri, Dec 6, 6:40 PM

this makes perfect sense, thanks sergey
i think a better solution than the current one (returning no vertex coordinate information at all) would be to just return the coordinates of a random adjacent face-corner when from instancer is cheked.
in the meantime i will continue looking for a way to fake it