Page MenuHome

Optix Viewport Render cancels when deleting an object
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce RTX 2080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.28

Blender Version
Broken: version: 2.82 (sub 2), branch: master, commit date: 2019-11-28 22:02, hash: rB77c744054062
Worked: (optional)

Addon Information
Name: Cycles Render Engine ()
Author:

Short description of error
When deleting, or making any other changes to a default blender scene the optix viewport render cancels.
Log spits out:
OptiX error OPTIX_ERROR_INVALID_VALUE in optixAccelBuild(context, NULL, &options, &build_input, 1, temp_mem.device_pointer, sizes.tempSizeInBytes, out_data.device_pointer, sizes.outputSizeInBytes, &out_handle, NULL, 0), line 876
Exact steps for others to reproduce the error
Can't avoid the error, it occurs in any attempt at a viewport render
Based on the default startup

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Tue, Dec 3, 11:09 AM

@Patrick Mours (pmoursnv): cant check here [no RTX], can you confirm?

Can reproduce. Only happens if you have zero objects in the scene. So the workaround is to simply not produce a scene with zero objects (as in, don't delete the last object).
But this is actually a bug in OptiX and not the integration in Cycles. A fix will be available in a future driver release (don't know when exactly yet, but likely beginning of January).

Brecht Van Lommel (brecht) lowered the priority of this task from Waiting for Developer to Reproduce to Confirmed, Medium.Fri, Dec 6, 7:33 PM