Page MenuHome

Metcaps - adding new ,etcap crashes app
Closed, ResolvedPublic

Description

I think I have found the problem. I have copied the files from BlenderCam to the subdirectory, and the scripts have been overridden. Also their was one .jpg file in the lights subdirectory, which I have removed, as the full install only has .exr files in that subdir. I can now click on the lights menu item without the system closing down.

System Information
Operating system:
Graphics card:

Ubuntu 18.04.3 LTS
Intel® UHD Graphics 620 (Kabylake GT2)


Blender Version
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen) Blender 2.81 installed from snap

Blender 2.81 (sub 16) System Information

Blender:

version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: 26bd5ebd42e3, type: Release
build date: 2019-11-20, 16:31:09
platform: Linux
binary path: '/snap/blender/34/blender'
build cflags: -Wall -Wcast-align -Werror=implicit-function-declaration -Werror=return-type -Werror=vla -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wnonnull -Wuninitialized -Wredundant-decls -Wshadow -Wno-error=unused-but-set-variable -fuse-ld=gold -std=gnu11 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -msse2 -D_GLIBCXX_USE_CXX11_ABI=0
build cxxflags: -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wformat-signedness -Wuninitialized -Wundef -Wmissing-declarations -fuse-ld=gold -std=c++11 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -msse2 -D_GLIBCXX_USE_CXX11_ABI=0
build linkflags: -Wl,--version-script='/home/sources/buildbot-x86_64-slave/linux_glibc217_x86_64_cmake/blender.git/source/creator/blender.map'
build system: CMake

Python:

version: 3.7.4 (default, Oct 8 2019, 15:23:02)
[GCC 6.3.1 20170216 (Red Hat 6.3.1-3)]
paths:
'/snap/blender/34/2.81/scripts/startup'
'/snap/blender/34/2.81/scripts/modules'
'/snap/blender/34/2.81/python/lib/python37.zip'
'/snap/blender/34/2.81/python/lib/python3.7'
'/snap/blender/34/2.81/python/lib/python3.7/lib-dynload'
'/snap/blender/34/2.81/python/lib/python3.7/site-packages'
'/snap/blender/34/2.81/scripts/freestyle/modules'
'/snap/blender/34/2.81/scripts/addons/modules'
'/home/pieter/.config/blender/2.81/scripts/addons/modules'
'/snap/blender/34/2.81/scripts/addons'
'/home/pieter/.config/blender/2.81/scripts/addons'

Python (External Binary):

binary path: '/snap/blender/34/2.81/python/bin/python3.7m'
version: Python 3.7.4

Directories:

scripts:
'/snap/blender/34/2.81/scripts/modules'
'/snap/blender/34/2.81/scripts'
'/home/pieter/.config/blender/2.81/scripts'
user scripts: '/home/pieter/.config/blender/2.81/scripts'
pref scripts: None
datafiles: '/home/pieter/.config/blender/2.81/datafiles/'
config: '/home/pieter/.config/blender/2.81/config/'
scripts : '/home/pieter/.config/blender/2.81/scripts/'
autosave: '/home/pieter/.config/blender/2.81/autosave/'
tempdir: '/tmp/blender_DWzFmM/'

FFmpeg:

avcodec: '58, 18, 100'
avdevice: '58, 3, 100'
avformat: '58, 12, 100'
avutil: '56, 14, 100'
swscale: ' 5, 1, 100'

SDL:

Version: 2.0.8
Loading method: dynamically loaded by Blender (WITH_SDL_DYNLOAD=ON)

Other Libraries:

OpenColorIO: 1, 1, 0
OpenImageIO: 1, 8, 13
OpenShadingLanguage: 1, 9, 9
OpenSubdiv: 0, 0, 0
OpenVDB: 5, 1, 0
Alembic: 1, 7, 8

OpenGL:

renderer: 'Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2) '
vendor: 'Intel Open Source Technology Center'
version: '4.5 (Core Profile) Mesa 19.0.8'
extensions:
GL_3DFX_texture_compression_FXT1
GL_AMD_conservative_depth
GL_AMD_depth_clamp_separate
GL_AMD_draw_buffers_blend
GL_AMD_gpu_shader_int64
GL_AMD_multi_draw_indirect
GL_AMD_query_buffer_object
GL_AMD_seamless_cubemap_per_texture
GL_AMD_shader_stencil_export
GL_AMD_shader_trinary_minmax
GL_AMD_texture_texture4
GL_AMD_vertex_shader_layer
GL_AMD_vertex_shader_viewport_index
GL_ANGLE_texture_compression_dxt3
GL_ANGLE_texture_compression_dxt5
GL_APPLE_object_purgeable
GL_ARB_ES2_compatibility
GL_ARB_ES3_1_compatibility
GL_ARB_ES3_2_compatibility
GL_ARB_ES3_compatibility
GL_ARB_arrays_of_arrays
GL_ARB_base_instance
GL_ARB_blend_func_extended
GL_ARB_buffer_storage
GL_ARB_clear_buffer_object
GL_ARB_clear_texture
GL_ARB_clip_control
GL_ARB_compressed_texture_pixel_storage
GL_ARB_compute_shader
GL_ARB_conditional_render_inverted
GL_ARB_conservative_depth
GL_ARB_copy_buffer
GL_ARB_copy_image
GL_ARB_cull_distance
GL_ARB_debug_output
GL_ARB_depth_buffer_float
GL_ARB_depth_clamp
GL_ARB_derivative_control
GL_ARB_direct_state_access
GL_ARB_draw_buffers
GL_ARB_draw_buffers_blend
GL_ARB_draw_elements_base_vertex
GL_ARB_draw_indirect
GL_ARB_draw_instanced
GL_ARB_enhanced_layouts
GL_ARB_explicit_attrib_location
GL_ARB_explicit_uniform_location
GL_ARB_fragment_coord_conventions
GL_ARB_fragment_layer_viewport
GL_ARB_fragment_shader
GL_ARB_fragment_shader_interlock
GL_ARB_framebuffer_no_attachments
GL_ARB_framebuffer_object
GL_ARB_framebuffer_sRGB
GL_ARB_get_program_binary
GL_ARB_get_texture_sub_image
GL_ARB_gpu_shader5
GL_ARB_gpu_shader_fp64
GL_ARB_gpu_shader_int64
GL_ARB_half_float_pixel
GL_ARB_half_float_vertex
GL_ARB_indirect_parameters
GL_ARB_instanced_arrays
GL_ARB_internalformat_query
GL_ARB_internalformat_query2
GL_ARB_invalidate_subdata
GL_ARB_map_buffer_alignment
GL_ARB_map_buffer_range
GL_ARB_multi_bind
GL_ARB_multi_draw_indirect
GL_ARB_occlusion_query2
GL_ARB_pipeline_statistics_query
GL_ARB_pixel_buffer_object
GL_ARB_point_sprite
GL_ARB_polygon_offset_clamp
GL_ARB_post_depth_coverage
GL_ARB_program_interface_query
GL_ARB_provoking_vertex
GL_ARB_query_buffer_object
GL_ARB_robust_buffer_access_behavior
GL_ARB_robustness
GL_ARB_sample_shading
GL_ARB_sampler_objects
GL_ARB_seamless_cube_map
GL_ARB_seamless_cubemap_per_texture
GL_ARB_separate_shader_objects
GL_ARB_shader_atomic_counter_ops
GL_ARB_shader_atomic_counters
GL_ARB_shader_ballot
GL_ARB_shader_bit_encoding
GL_ARB_shader_clock
GL_ARB_shader_draw_parameters
GL_ARB_shader_group_vote
GL_ARB_shader_image_load_store
GL_ARB_shader_image_size
GL_ARB_shader_objects
GL_ARB_shader_precision
GL_ARB_shader_stencil_export
GL_ARB_shader_storage_buffer_object
GL_ARB_shader_subroutine
GL_ARB_shader_texture_image_samples
GL_ARB_shader_texture_lod
GL_ARB_shader_viewport_layer_array
GL_ARB_shading_language_420pack
GL_ARB_shading_language_packing
GL_ARB_stencil_texturing
GL_ARB_sync
GL_ARB_tessellation_shader
GL_ARB_texture_barrier
GL_ARB_texture_buffer_object
GL_ARB_texture_buffer_object_rgb32
GL_ARB_texture_buffer_range
GL_ARB_texture_compression_bptc
GL_ARB_texture_compression_rgtc
GL_ARB_texture_cube_map_array
GL_ARB_texture_filter_anisotropic
GL_ARB_texture_float
GL_ARB_texture_gather
GL_ARB_texture_mirror_clamp_to_edge
GL_ARB_texture_multisample
GL_ARB_texture_non_power_of_two
GL_ARB_texture_query_levels
GL_ARB_texture_query_lod
GL_ARB_texture_rectangle
GL_ARB_texture_rg
GL_ARB_texture_rgb10_a2ui
GL_ARB_texture_stencil8
GL_ARB_texture_storage
GL_ARB_texture_storage_multisample
GL_ARB_texture_swizzle
GL_ARB_texture_view
GL_ARB_timer_query
GL_ARB_transform_feedback2
GL_ARB_transform_feedback3
GL_ARB_transform_feedback_instanced
GL_ARB_transform_feedback_overflow_query
GL_ARB_uniform_buffer_object
GL_ARB_vertex_array_bgra
GL_ARB_vertex_array_object
GL_ARB_vertex_attrib_64bit
GL_ARB_vertex_attrib_binding
GL_ARB_vertex_buffer_object
GL_ARB_vertex_shader
GL_ARB_vertex_type_10f_11f_11f_rev
GL_ARB_vertex_type_2_10_10_10_rev
GL_ARB_viewport_array
GL_ATI_blend_equation_separate
GL_ATI_texture_float
GL_EXT_abgr
GL_EXT_blend_equation_separate
GL_EXT_draw_buffers2
GL_EXT_draw_instanced
GL_EXT_framebuffer_blit
GL_EXT_framebuffer_multisample
GL_EXT_framebuffer_multisample_blit_scaled
GL_EXT_framebuffer_object
GL_EXT_framebuffer_sRGB
GL_EXT_packed_depth_stencil
GL_EXT_packed_float
GL_EXT_pixel_buffer_object
GL_EXT_polygon_offset_clamp
GL_EXT_provoking_vertex
GL_EXT_shader_framebuffer_fetch
GL_EXT_shader_framebuffer_fetch_non_coherent
GL_EXT_shader_integer_mix
GL_EXT_shader_samples_identical
GL_EXT_texture_array
GL_EXT_texture_compression_dxt1
GL_EXT_texture_compression_rgtc
GL_EXT_texture_compression_s3tc
GL_EXT_texture_filter_anisotropic
GL_EXT_texture_integer
GL_EXT_texture_sRGB
GL_EXT_texture_sRGB_decode
GL_EXT_texture_shared_exponent
GL_EXT_texture_snorm
GL_EXT_texture_swizzle
GL_EXT_timer_query
GL_EXT_transform_feedback
GL_EXT_vertex_array_bgra
GL_EXT_vertex_attrib_64bit
GL_IBM_multimode_draw_arrays
GL_INTEL_conservative_rasterization
GL_INTEL_performance_query
GL_INTEL_shader_atomic_float_minmax
GL_KHR_blend_equation_advanced
GL_KHR_blend_equation_advanced_coherent
GL_KHR_context_flush_control
GL_KHR_debug
GL_KHR_no_error
GL_KHR_robust_buffer_access_behavior
GL_KHR_robustness
GL_KHR_texture_compression_astc_ldr
GL_KHR_texture_compression_astc_sliced_3d
GL_MESA_pack_invert
GL_MESA_shader_integer_functions
GL_MESA_texture_signed_rgba
GL_NV_conditional_render
GL_NV_depth_clamp
GL_NV_fragment_shader_interlock
GL_NV_packed_depth_stencil
GL_NV_texture_barrier
GL_OES_EGL_image
GL_S3_s3tc

Implementation Dependent OpenGL Limits:

Maximum DrawElements Vertices: 3000
Maximum DrawElements Indices: 3000

GLSL:
Maximum Varying Floats: 128
Maximum Vertex Attributes: 16
Maximum Vertex Uniform Components: 16384
Maximum Fragment Uniform Components: 16384
Maximum Vertex Image Units: 32
Maximum Fragment Image Units: 32
Maximum Pipeline Image Units: 192

Cycles:

CPU device capabilities: SSE2 SSE3 SSE41 AVX AVX2

Enabled add-ons:

io_anim_bvh (version: (1, 0, 0), path: /snap/blender/34/2.81/scripts/addons/io_anim_bvh/__init.py)
io_curve_svg (version: UNKNOWN, path: /snap/blender/34/2.81/scripts/addons/io_curve_svg/
init.py)
io_mesh_ply (version: (1, 0, 0), path: /snap/blender/34/2.81/scripts/addons/io_mesh_ply/
init.py)
io_mesh_stl (version: (1, 1, 3), path: /snap/blender/34/2.81/scripts/addons/io_mesh_stl/
init.py)
io_mesh_uv_layout (version: (1, 1, 1), path: /snap/blender/34/2.81/scripts/addons/io_mesh_uv_layout/
init.py)
io_scene_fbx (version: (4, 20, 2), path: /snap/blender/34/2.81/scripts/addons/io_scene_fbx/
init.py)
io_scene_gltf2 (version: (1, 0, 5), path: /snap/blender/34/2.81/scripts/addons/io_scene_gltf2/
init.py)
io_scene_obj (version: (3, 7, 0), path: /snap/blender/34/2.81/scripts/addons/io_scene_obj/
init.py)
io_scene_x3d (version: (2, 2, 5), path: /snap/blender/34/2.81/scripts/addons/io_scene_x3d/
init.py)
cycles (version: UNKNOWN, path: /snap/blender/34/2.81/scripts/addons/cycles/
init.py)
space_view3d_pie_menus (version: (1, 2, 9), path: /snap/blender/34/2.81/scripts/addons/space_view3d_pie_menus/
init.py)
space_view3d_spacebar_menu (version: (1, 9, 4), path: /snap/blender/34/2.81/scripts/addons/space_view3d_spacebar_menu/
init.py)
space_view3d_3d_navigation (version: (1, 2, 5), path: /snap/blender/34/2.81/scripts/addons/space_view3d_3d_navigation.py)
btrace (version: (1, 2, 3), path: /snap/blender/34/2.81/scripts/addons/btrace/
init.py)
curve_tools (version: (0, 4, 0), path: /snap/blender/34/2.81/scripts/addons/curve_tools/
init.py)
add_curve_extra_objects (version: (0, 1, 3), path: /snap/blender/34/2.81/scripts/addons/add_curve_extra_objects/
init.py)
io_export_dxf (version: (2, 2, 3), path: /snap/blender/34/2.81/scripts/addons/io_export_dxf/
init.py)
io_export_paper_model (version: (1, 1), path: /snap/blender/34/2.81/scripts/addons/io_export_paper_model.py)
io_import_dxf (version: (0, 9, 6), path: /snap/blender/34/2.81/scripts/addons/io_import_dxf/
init.py)
io_import_images_as_planes (version: (3, 3, 1), path: /snap/blender/34/2.81/scripts/addons/io_import_images_as_planes.py)
io_shape_mdd (version: (1, 0, 1), path: /snap/blender/34/2.81/scripts/addons/io_shape_mdd/
init.py)
space_view3d_align_tools (version: (0, 3, 4), path: /snap/blender/34/2.81/scripts/addons/space_view3d_align_tools.py)
space_view3d_modifier_tools (version: (0, 2, 6), path: /snap/blender/34/2.81/scripts/addons/space_view3d_modifier_tools.py)
materials_library_vx (version: (0, 5, 9), path: /snap/blender/34/2.81/scripts/addons/materials_library_vx/
init.py)
materials_utils (version: (2, 2, 0), path: /snap/blender/34/2.81/scripts/addons/materials_utils/
init.py)
object_print3d_utils (version: UNKNOWN, path: /snap/blender/34/2.81/scripts/addons/object_print3d_utils/
init.py)
mesh_auto_mirror (version: (2, 5, 2), path: /snap/blender/34/2.81/scripts/addons/mesh_auto_mirror.py)
mesh_bsurfaces (version: (1, 7, 1), path: /snap/blender/34/2.81/scripts/addons/mesh_bsurfaces.py)
mesh_tools (version: (0, 3, 6), path: /snap/blender/34/2.81/scripts/addons/mesh_tools/
init__.py)

Worked: (optional)

Short description of error
Trying to add new metcaps via preferences- lights. App closes as soon as you click on the lights menu option

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
Default "General" startup file.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Tue, Dec 3, 9:39 AM

I cannot reproduce this with either the latest stable or current development versions of Blender:

Please try the latest daily build: https://builder.blender.org/download/

Go to File → Defaults → Load Factory Settings and then check again if you still can reproduce this issue.

Also: are there already other files in blender/2.82/datafiles/studiolights/ ? Does this still crash if you remove those as a test?

Pieter (pviljoen) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) closed this task as Resolved.Wed, Dec 4, 9:37 AM
Philipp Oeser (lichtwerk) claimed this task.

I can now click on the lights menu item without the system closing down.

Think we can close this then...
(feel free though to comment again if issues persist...)