Page MenuHome

Brush Size not accurate on hiDPI retina screen
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-19.0.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 560X OpenGL Engine ATI Technologies Inc. 4.1 ATI-3.2.24

Blender Version
Broken: version: 2.82 (sub 4), branch: master, commit date: 2019-12-10 23:56, hash: rB63d521432e93
Worked: (optional)

Short description of error
When setting the Brush Size in Particle Edit mode it displays one size (first pic) and after you confirm it shows it way bigger. The actual area of the brush that works is the right one though, the one you chose before confirming.

Event Timeline

Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Needs Information from User.Dec 29 2019, 3:28 PM

Seems to work for me. Please provide a simple .blend file that allows me to reproduce the issue.

This is not specific to a project... There's a way to reproduce this in the default file in 50s, I recorded it.
You can see the brush behaviour is very inconsistent in the Particle Edit.

Jacques Lucke (JacquesLucke) changed the task status from Needs Information from User to Needs Triage.Dec 31 2019, 1:40 PM
Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Jan 8 2020, 7:07 PM

I cannot reproduce this with either the latest stable or current development versions of Blender.
Is this a problem with your keymap settings?

Please try the latest daily build: https://builder.blender.org/download/
Go to File → Defaults → Load Factory Settings and then load your file to see if you still can reproduce this issue.

If the problem persists, please give us more clear instructions on how to reproduce it from scratch.

Tested on todays build and now the problem is only that the Brush size isn't accurate once you "release" when resizing.
Everything on the brush radius is moving but it isn't on the size I set it to be (when using the F shortcut).

Germano Cavalcante (mano-wii) changed the task status from Needs Information from User to Needs Developer to Reproduce.Jan 9 2020, 6:51 PM

As hard as I try, I can't reproduce the problem:

Philipp Oeser (lichtwerk) changed the task status from Needs Developer to Reproduce to Needs Information from User.Jan 9 2020, 6:58 PM

Also cannot reproduce this here.
Just to be totally sure we are all on the same page: could you share your .blend?

Sure! There you go:

I loaded the factory settings as asked for the test I posted.
Maybe it's Mac related? It often is when I report bugs...

Interesting that you mention that the problem happens when you release.
But by default the brush is applied when you press the mouse button.
This makes me suspect that your keymap is different.

Just the wrong word used... You can see me struggling with the Tab shortcut because of the "Load Factory Settings" on the video.

The thing I did was:
F > Slide to scale > F again to apply (what I meant by release).

The thing I did was:
F > Slide to scale > F again to apply (what I meant by release).

I can not press F to apply

I have to do F > Slide to scale > Click to apply

Richard Antalik (ISS) closed this task as Invalid.Jan 26 2020, 3:02 AM
Richard Antalik (ISS) claimed this task.

Will close this report because of no new info, that would help us to reproduce the issue.

I gave all the info I had... you can see in the video how it behaves. It’s probably Mac related so a Mac developer could probably reproduce.

Richard Antalik (ISS) reopened this task as Needs Developer to Reproduce.Jan 27 2020, 1:46 PM

I can reopen this, but there are numerous issues with macOS currently, because openGL is no longer supported on that platform. Therefore we can not guarantee fix even if issue could be reproduced.

It depends on the pixel density of a screen.
If you "Open in Low Resolution", then all will work fine.
When you adjust "Brush Size" (F) you see a circle with a radius without taking into account the hiDPI.

Richard Antalik (ISS) renamed this task from Brush Size display not accurate in Particle Edit to Brush Size not accurate on hiDPI retina screen.Jan 27 2020, 4:30 PM

@Yevgeny Makarov (jenkm) Thanks for more info.

@Brecht Van Lommel (brecht) here's the patch for that.

diff --git a/source/blender/editors/physics/particle_edit.c b/source/blender/editors/physics/particle_edit.c
index 92e76ab31fa..52ba27902da 100644
--- a/source/blender/editors/physics/particle_edit.c
+++ b/source/blender/editors/physics/particle_edit.c
@@ -207,7 +207,7 @@ static float pe_brush_size_get(const Scene *UNUSED(scene), ParticleBrushData *br
   // UnifiedPaintSettings *ups = &scene->toolsettings->unified_paint_settings;
   // float size = (ups->flag & UNIFIED_PAINT_SIZE) ? ups->size : brush->size;
 
-  return brush->size * U.pixelsize;
+  return brush->size;
 }
 
 PTCacheEdit *PE_get_current_from_psys(ParticleSystem *psys)