Page MenuHome

2.82 Texture Paint/UDIM - color sampling always samples only 1st tile when using UDIMS
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.17763-SP0 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2019-12-21 17:23, hash: rBa0892bb690fe
Worked: (optional)

Short description of error
I've been playing with new UDIM features (which are awesome by the way!) and discovered a couple of small bugs:

  • Sampling in Texture paint mode (3D view) only samples first UDIM tile

here's a video demo showing the issue

  • Another issue, also related to First tile UDIM is "Edit Externally" only opens first tile

in this case, a possible fix would be to open the file that's currently highlighted in UDIM menu

Exact steps for others to reproduce the error

-Open untitled3.blend
-enter the texture paint mode on 3D view
-try to paint sofa/table/TV
-notice that color sampling in texture paint mode only samples from first UDIM tile, ignoring all the rest

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Mon, Jan 13, 2:21 PM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".

Hi and thx for the report!

Can confirm the (first) issue (color sampling only going for the 1st tile).
This one I would also consider a bug.
Maybe we need a more generic solution than adding this to each and every operator etc [rBf9e65fcea72f, T72390 are related]?

Another issue, also related to First tile UDIM is "Edit Externally" only opens first tile...

Please report this separately [it is related, but it is more practical to have these tackled one by one...] and remove that second issue from the task description.