Page MenuHome

Gizmos blink when selecting with right mouse button
Confirmed, LowPublicDESIGN

Description

System Information
Windows 10 64 Bits.
Graphics card GeForce GTX 1080 Ti.

Blender Version
Broken: version: 2.82.6, branch: master, commit date: 2019-12-27 12:51, hash: rBd2dc4f84115c
Worked: 2.79b, 2.80 & 2.81.

Short description of error
Whenever you select or extend select the gizmos do a quick blink.

Exact steps for others to reproduce the error

  • I have a custom keymap that changed the type of event from Click to Press for the default.
  • This issue can easily be replicated if you use the Right Click Select.
  • Default Cube subdivided then Select few Vertices in a normal manner like shown in the Gif.

[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Steps to reproduce:

  1. Open default file.
  2. Use right click select.
  3. Enter edit mode on the default cube.
  4. Enable the move tool.
  5. Right click to select vertices of the cube.

Whenever, the mouse button is down, the gizmo disappears.

@Campbell Barton (campbellbarton), is this a bug, limitation or working as intended?

Campbell Barton (campbellbarton) closed this task as Invalid.EditedWed, Jan 15, 8:41 AM

This is working as intended, without this - the gizmo flashes on and off when tweaking the mesh.

This video shows what happens when tweaking vertices with this behavior disabled.

CobraA (CobraA) added a comment.EditedWed, Jan 15, 11:56 AM

This is working as intended, without this - the gizmo flashes on and off when tweaking the mesh.
This video shows what happens when tweaking vertices with this behavior disabled.

This is about selection without tweaking.

In versions of 2.80 & 2.81 this worked correctly so something has changed since then.

The current behavior is needed to support gizmo and tool interaction, so gizmos don't "catch" a tools interaction by appearing under an event which was intended for a tool T66304: Tools, Selection & Gizmo design.

  • Enter edit-mode.
  • Select the tweak tool.
  • Select the transform tool.
  • Click and drag on a vertex to move it.
  • The gizmo draws under the mouse cursor, catching the draw event that was intended for the tweak tool.

This video shows the problem (notice the second click-drag doesn't tweak).


If the flickering issue is considered a bad enough problem, we could prevent the flickering while keeping this behavior.

Personally I don't find this so bad, and there is even added flickering if this behavior is reverted (as mentioned in my previous video).

So I would like to get feedback from the UI team on this one.

Marking as a design task.

Campbell Barton (campbellbarton) renamed this task from Gizmos blink whenever you select. to Gizmos blink when selecting with right mouse button.Fri, Jan 17, 5:59 PM
Campbell Barton (campbellbarton) reopened this task as Confirmed.
Campbell Barton (campbellbarton) triaged this task as Low priority.
Campbell Barton (campbellbarton) changed the subtype of this task from "Report" to "Design".

flickering is bad enough if you have to (shift) select thousands of verts,edges and faces on a daily basis, this seems like adding more complexity when there is already a tweak tool that does the job.