Page MenuHome

Texture Paint: Shortcut 'Shift + S' Does Not Save an Image
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Linux-5.0.0-37-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1660 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version
Broken:

  • version: 2.82 (sub 6), branch: master, commit date: 2019-12-30 15:42, hash: rB03145616843e
  • version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3
  • version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e

Short description of error
Using the default shortcut Shift + S does not perform the action to save an image. Neither in the Image Editor window nor in the UV Editor window.

Exact steps for others to reproduce the error

  1. Open Blender
  2. Choose General in the Splash Screen
  3. Choose the Texture Paint workspace in the top menu
  4. In the left window: Click the + New button in the header and press OK
  5. Still in the left window: Press Shift + S (which should open a file browser to save the image. But it does not.)

Event Timeline

ronsn created this task.Dec 30 2019, 7:53 PM

This looks like a mistake in the keymap, and things are conflicting...
"Shif + S" toggles the smooth stroke, that's why it's not saving...
I believe the shortcut for that "Save As..." is meant to be "Shift + Alt + S".

ronsn closed this task as Resolved.Jan 1 2020, 9:00 PM
ronsn claimed this task.

@TheRedWaxPolice (TheRedWaxPolice) Shift + Alt + S does not work. At least not on Linux^^

ronsn added a comment.Jan 1 2020, 9:04 PM

:o Why is that task resolved?

@TheRedWaxPolice (TheRedWaxPolice) Shift + Alt + S does not work.

Ofc not. I meant that shift + alt + s is what should be there, not shift + s.

Ray molenkamp (LazyDodo) reopened this task as Needs Triage.Jan 1 2020, 9:32 PM

closed by accident by @ronsn somehow.

ronsn removed ronsn as the assignee of this task.Jan 1 2020, 11:16 PM
ronsn added a subscriber: Christopher_Anderssarian.
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Jan 13 2020, 3:30 PM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".

Can confirm.

I believe the shortcut for that "Save As..." is meant to be "Shift + Alt + S".

I believe so, too.