Page MenuHome

Sculpt Mode Project TODO
Closed, ArchivedPublicTO DO

Assigned To
None
Authored By
Pablo Dobarro (pablodp606)
Jan 28 2020, 4:34 AM
Tokens
"Like" token, awarded by cfnjrey."Love" token, awarded by Pipeliner."Love" token, awarded by kenziemac130."Like" token, awarded by Constantina32."Pterodactyl" token, awarded by Way."Love" token, awarded by Stig."Love" token, awarded by nunoconceicao."Love" token, awarded by avpiedra."Love" token, awarded by Xlindvain."Love" token, awarded by lucasfalcao."Yellow Medal" token, awarded by franMarz."Love" token, awarded by jubi."Love" token, awarded by dbystedt."Love" token, awarded by kynu."Love" token, awarded by brilliant_ape."Love" token, awarded by RodDavis."100" token, awarded by Floatharr."Love" token, awarded by shader."100" token, awarded by tiagoffcruz."Love" token, awarded by xrg."100" token, awarded by Frozen_Death_Knight."Love" token, awarded by Brandon777.

Description

This task keeps track of the tasks that need to be tackled to consider the Sculpt Mode finished and ready to use in production.

After completing all these tasks, Blender should have a perfectly functional sculpting workflow for creating stylized sculpts.

Note that some other task and features not listed here can be development in the meantime or in the future. This is a list of the minimum functionality Blender should provide to avoid users running into obvious software limitation during their workflow.

This list is only focused on stylized sculpting. Supporting high poly sculpting to this same level of feature polishing is a much bigger project that needs a completely different set of features to be designed and developed (most of them related to texture projection options and brush/alpha management currently missing in Blender and limited by the deprecated Texture datablock).

Not Possible Workaround

These task are related to features that are not working and they don’t have any possible workaround or alternative in Blender.

  • T73317 Multires Detail Propagation
  • T73317 Multires Rebuild/Subdivide levels

Not Functional Workaround

These task are about features that are currently available in some form, but due to some design/performance issues they are not usable for a sculpting workflow:

  • T71951 Sculpt Mode with Multiple Objects: Update Keymap, Multithreaded PBVH building, cache the SculptSession, update Overlays...
  • T71946 D5975 Sculpt Vertex Colors: MVertCol Layer, Paint Brush, Remesher, Color Filter, Multires support.
  • T71946 D6070 Visibility Management: Something that provides the same functionality as sculpt Face Groups, Multires support.
  • Brush Management: 2.83 will include brush tool updates that will require more than a preset per tool. This may require a global brush palette to make the system usable for new users (they don’t know which tool correspond to each brush).
  • D6269 Delay Viewport Updates: Fix the viewport lag after a full mesh update operation.
  • T71759 Undo brush properties bug in sculpt and paint modes

Incomplete Tools

These features are related to a certain tool. They limit the usability and the scope of a particular tool, but they do not affect the sculpting workflow as a whole.

  • D6705 Edge Automasking
  • D7059 Topological Falloff
  • D6156 Texture Mesh Filter
  • D6449 Edit Voxel Size Operator (or fix the PBVH rebuild bug)
  • Transform tool: Orientations and view gizmo during transform.
  • Transform tool: Move pivot position independently.

Missing Features

These features are currently not optimal to be used in Sculpt Mode, but we have other functional features in Blender to do the same thing.

Event Timeline

Campbell Barton (campbellbarton) changed the task status from Needs Triage to Confirmed.Jan 28 2020, 6:27 AM
Campbell Barton (campbellbarton) changed the subtype of this task from "Report" to "To Do".
Way awarded a token.Mar 6 2020, 4:27 PM
Brecht Van Lommel (brecht) closed this task as Archived.Apr 6 2022, 7:07 PM

Closing outdated planning task.