Page MenuHome

Knife tool Cut Through not possible in IC Keymap
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10 64 Bits
Graphics card: Radeon RX Vega ATI Technologies Inc. 4.5.13586 Core Profile Context 19.12.2 26.20.15002.61

Blender Version
Broken: version: 2.83 (sub 2), branch: master, commit date: 2020-01-31 22:07, hash: rBdc3f073d1c52
Worked: (optional)

Knife Tool not working as intended

Not sure if it's right to call this a bug. But it's definitely a flaw, thats breaking the tools intended functionality.
I posted it a week ago in the devtalk forums as I think fixing it is not such a big thing. But seems it got overread.

Should these sort of problems get reported as bug or not?

Description: Within the IC Keymap the toggle for Cut Through is simply not available
Here's a screenshot of the blender keymap settings.
! This is missing within the IC Keymap !

It's promoted in the infobar. But it can't be triggered at all

Exact steps for others to reproduce the error

  1. Open default Scene.
  2. Choose Knife tool via shortcut or toolbar.
  3. Click outside the cube and drag the knife line across the cube
  4. Try hitting Z as displayed in the infobar to toggle to cut through.

Event Timeline

William Reynish (billreynish) changed the task status from Needs Triage to Confirmed.Sat, Feb 1, 3:19 PM

Not missing, but there is a keymap conflict.

Yes, you are right with that, the entry itself is there.

Tagging as user interface since the whole IC keymap is handled there.

Julian Eisel (Severin) closed this task as Resolved.Tue, Feb 18, 6:41 PM

In the IC keymap this uses the X key now instead. This works fine for me.
So guess this can be closed as resolved. Thanks for the report either way.