Page MenuHome

Boolean modifier doesn't work as expected
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 64 bits

Blender Version
Broken in: 2.81 release, 2.82 beta, 2.83 alpha (to the date of posting this)

Short description of error
Whether it's the union, intersect or difference option is selected, the resulting mesh is not what expected out of the boolean modifier.

Exact steps for others to reproduce the error
Just turn the modifier on in the file provided:

Event Timeline

Hi, the boolean operators (those two cylinders on your example) are overlapping each other. With the actual boolean code you need to have mainfold geometry to work with. Not a bug, but I'm also reluctant to consider it a "known issue" or a limitiation.

Thanks.

I can see the issue, but I do not know if an overlapping mesh is supported.

The "Circle" object in this file is not a watertight single volume. This is not supported by the current code.

Indeed, you all are right. When I have the mesh non-intersecting or made into a manifold geometry, the boolean behaves correctly.

Stephen Swaney (stiv) closed this task as Resolved.Feb 6 2020, 12:47 AM
Stephen Swaney (stiv) claimed this task.

Closed as being a known issue or limitation. Thanks for reporting.