Page MenuHome

Collection instance doesn't inherit exclude from view layer status
Closed, InvalidPublic

Description

Blender Version
Broken: Blender 2.82.6

Exact steps for others to reproduce the error

  1. Open file
  2. Switch to Modeling workspace
  3. Toggle Exclude Form View Layer checkbox on Parent_stuff collection

Instances are not excluded

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Feb 10 2020, 11:22 AM

Could you share an example .blend file?
(This way it is easier to reproduce and makes sure we are all looking at the same thing...)

"Disable from View Layer"

Are you talking about "Exclude from View Layer"?

you would like to use layers

Are you talking about View Layers (or rather Collections)?

but the instance should do as the parent does! So... if I tell the parent to go away from a layer... the instances should follow.

Not in all cases (that is if we are talking about the parent being a collection -- see question above), an instance could be in multiple collections, excluding one parent collection from the viewlayer could still have a child instance included in another collection.

Note: if you +click "Disable in Viewports" / "Disable in Renders" on a parent collection, this will propagate to child instances in any other collection as well...

Hi,

Here is a small file with two layers.

  1. I did a collection of a monkey, torus and cylinder. This is called Parent_Stuff
  2. I did instances of that collection. They then got the name Parent_Stuff.001 to Parent_Stuff.006
  3. Now I will have one layer with ONLY the sun (because I'm going to blur and add a lot of effects on it in the compositor). I do not want any other things on this layer. So, I select "Parent_Stuff" -> View_Layer -> Disable from View Layer in the layer called "Only_Sun"
  4. I try to find similar things on the instances, but that option does not exist. Nor does they vanish when I select 3) on the "Parent_Stuff". I can't use "Globally deselect on render" because I want them to be in in the other layer.
  5. In my first Layer "Parent_Stuff_On", I remove the sun... but let it still shine on the things using View_Layer -> Set Indirecr only. This works fine on all instances... and the parent...and the sun is gone as it is supposed to.

So...it is number 4) I can't seem to do with instances of collections.

Br
Joakim

Richard Antalik (ISS) renamed this task from Scene instance can't be disabled from View Layer to Collection instance doesn't inherit exclude from view layer status.Feb 11 2020, 10:48 PM
Richard Antalik (ISS) updated the task description. (Show Details)

I am not too much wiser after reading manual, but I would expect this to work in similar way as Enable in Viewports, just for active view layer.

Sorry, but I'm not following your comment, but it could me that get it wrong here.
We have different instances of collections... but they are in the same view layer... both parent collection and the instances of collections.
I'll try to hide ALL in one layer...but that is not possible.
One layer, in my example above, has only the light/sun, Another layer (with all instances) has all the objects.
So, amount of View Layers doesn't matter. I don't have the parent in one layer and try to hide instances in the other.
It does not work to hide collection instances...no matter what you do or in what layer you have them, if you do not exclude them totally from render and that is not the purpose. I need them in the render, but not together with the background :).

I have edited report title, and I think that it is pretty good summary of what you describe.

In my comment I am just saying, that behavior of that checkbox is not described in enough detail in manual to triage this report.

Philipp Oeser (lichtwerk) claimed this task.

The original collection the instances were made from, and the instances themselves are not the same in regards to their membership in viewlayers.

To set this up properly, why dont you use a parent collection for the instances?
This way you can exclude this parent collection from one viewplayer, but not the other:

Sorry, this might be still a misunderstanding, but this is how you would organize per viewlayer visibility for everything (not just instances): you would organize them in collections.
https://docs.blender.org/manual/en/dev/render/layers/layers.html#usage

I will close this for now, but feel free to comment again if issues persist...