Page MenuHome

Nodes Editor laggy
Closed, ResolvedPublic

Description

System Information
Operating system:Windows 10 1903
Graphics card:MSI Geforce GTX 1080

Blender Version
Broken:
2.80.15 but i have uninstalled it
2.81 (sub 16), branch: master, commit date: 2019-12-04 11:32, hash: f1aa4d18d49d, type: Release build date: 2019-12-04, 14:30:40
2.83 (sub 2), branch: arcpatch-D6715_1, commit date: 2020-02-02 04:40, hash: ede18a800832, type: Release build date: 2020-02-02, 04:42:11

Short description of error
In the Shader Editor and the compositor the zoom is very steppy and becomes slower and slower as the maximum zoom approaches. If the node editor is empty there is no problem, zoom in and out are fluids.

I ended up finding that by unchecking "Translation" in the "Preferences > Interface" the problem disappeared.
Whatever type of translation we choose (all / none / some) the issue persists. The only way i found is to uncheck "Translation"

Hope it could help to fix the issue soon

Event Timeline

This problem has already been reported in T46463 but no developer has been able to detect the problem in the code.
I can reproduce a slight delay, but nothing too serious.
It may not be the same problem, but I will investigate.

Thanks for the reply.
Since yesterday I tried on a second machine and still the same issue.
I tought maybe it cames from my computer but it seems not.

I've searched for it ... sorry for the duplicate entry about this problem, this is my first rodeo ;)

I believe that rBa21f5ec56245 fixed the problem, but please confirm tomorrow in the daily builds.
So we can reopen the report if the problem still exists.

https://builder.blender.org/download/

The issue still remains for me with the new branch
Anyway you guys are really amazing
Thanks for all your hard and good work. Blender is a dream and an oasis in this cruel and cold world
Regards