Page MenuHome

Import of gltf files does not maintain image filenames
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional) 2.81 Has the same behavior

Short description of error
After importing a gltf file. The filepath attribute for the image has a random name with no extension. (Its probably a temp file name create as part of the import process)

Exact steps for others to reproduce the error
Import a gltf file into the default blend.
Save as a blender file in a new directory
Close blender and open the new file by double clicking, or file open.
go to File -> External Data -> Unpack all into files -> Use files in current directory
a textures folder will be created in the new directory
the files in the textures directory will not have the names or extensions that were in the gltf file. Or as displayed in the blend file.

Blender does know the names of the image files as they can be seen in the outliner under blender file-> images. and in the image nodes in the shader editor.

If a blender files is created from scratch and images are packed into it file names appear to be preserved.

The attached zip came from url below. Other GLTF files from this site have the same image filename problem.
https://sketchfab.com/3d-models/geth-normale-trooper-2727eac05b184aee83b8affe7f8fb84f

Event Timeline

Scott (Scotty918) updated the task description. (Show Details)
Ankit (ankitm) added a project: Import/Export.
Richard Antalik (ISS) closed this task as Resolved.Feb 17 2020, 11:58 AM
Richard Antalik (ISS) claimed this task.

Seems to be fixed in 2.83.

Can't find relevant commit