Page MenuHome

UnicodeDecodeError error importing file into .obj and .glb / .gltf format
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1060 3GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 432.00

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional)

Short description of error
error importing file into .obj and .glb / .gltf format

Exact steps for others to reproduce the error
first, when importing a file into the .obj format, such an error appeared

 Traceback (most recent call last):
  File "D: \ Blender \ 2.81 \ scripts \ addons \ io_scene_obj \ __ init__.py", line 145, in execute
    return import_obj.load (context, ** keywords)
  File "D: \ Blender \ 2.81 \ scripts \ addons \ io_scene_obj \ import_obj.py", line 962, in load
    float_func = get_float_func (filepath)
  File "D: \ Blender \ 2.81 \ scripts \ addons \ io_scene_obj \ import_obj.py", line 867, in get_float_func
    file = open (filepath, 'rb')
FileNotFoundError: [Errno 2] No such file or directory: 'Z: \\ New Folder \\ ookii heya \\ wprogu \\ mnogoetazka v 1.4 untitled.blend'

location: <unknown location>: - 1

then when I changed the file name and location, such an error appeared

bpy.context.space_data.recent_folders_active = 0

Traceback (most recent call last):
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_obj \ __ init__.py", line 146, in execute
    return import_obj.load (context, ** keywords)
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_obj \ import_obj.py", line 974, in load
    float_func = get_float_func (filepath)
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_obj \ import_obj.py", line 881, in get_float_func
    file = open (filepath, 'rb')
FileNotFoundError: [Errno 2] No such file or directory: 'D: \\ bild \\ building.blend'

location: <unknown location>: - 1

and when you try to import the file into the .glb / .gltf format, this error appears

Traceback (most recent call last):
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_gltf2 \ __ init__.py", line 850, in execute
    return self.import_gltf2 (context)
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_gltf2 \ __ init__.py", line 864, in import_gltf2
    if self.unit_import (path, import_settings) == {'FINISHED'}:
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_gltf2 \ __ init__.py", line 877, in unit_import
    success, txt = self.gltf_importer.read ()
  File "D: \ blend \ blender \ 2.82 \ scripts \ addons \ io_scene_gltf2 \ io \ imp \ gltf2_io_gltf.py", line 162, in read
    content = str (self.content, encoding = 'utf-8')
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe3 in position 21: invalid continuation byte

location: <unknown location>: - 1]{F8348794}

Event Timeline

Ankit (ankitm) renamed this task from bpy.context.space_data.recent_folders_active = 0 Traceback (most recent call last): ? to UnicodeDecodeError error importing file into .obj and .glb / .gltf format.Feb 19 2020, 8:31 AM
Ankit (ankitm) updated the task description. (Show Details)

Could you add simple files, to help debug the issue, to the report please?
P.S.: T73825 is about export failing, though could be unrelated.

Ankit (ankitm) changed the task status from Needs Triage to Needs Information from User.Feb 19 2020, 8:38 AM

what do you mean by simple files?
which files are needed?

The ones you're trying to import

This comment was removed by Grigoryi (matamatsuda).

Hello,

Your bug report is about importing .obj or .glb issue, but your provided files are .blend
Please provide the .obj or .glb you can't import, this is the only way for devs to reproduce the issue. (Or update your bug description if the problem is not about importing)

I think you want to export what is in your .blend files as .obj

Grigoryi (matamatsuda) closed this task as Resolved.Feb 19 2020, 9:53 PM
Grigoryi (matamatsuda) claimed this task.

yes thanks already figured out