Page MenuHome

GreasePencil - Gradientfill doesn't get rendered
Closed, ResolvedPublic

Description

System Information
Operating system: Manjaro Linux x86_64, Kernel 5.4.23-1-MANJARO
Graphics card: Intel Haswell-ULT (MESA

Blender Version
Broken: 2.83 (sub6), branch: greasepencil-object, commit-date: 2020-03-04 21:12, hash: d503af9a6173, type: Release, build-date: 2020-03-04, 21:39:42
Worked: unknown

Short description of error
When a material of a grease pencil stroke object has "Gradient" selected as Fill, it only shows the fill with the first color in Render Result. Render Preview works fine.

Exact steps for others to reproduce the error

  • Start a "2D Animation" default file
  • draw any shape with "Solid Fill" material
  • change the fill option of the material from Solid to Gradient
  • (optional) for the second color choose something easier to destinguish like RGBA 1,0,0,1
  • set viewport to "Renderd" -> the gradient still should look fine
  • Render (eg. with F12) -> the shape is filled only with the primary color of the gradient (same as solid fill)
  • settings like the gradient type (linear, radial) modifiers, visual effects or lights etc. seem to have no effect

Event Timeline

Can not reproduce here
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Radeon RX550/550 Series ATI Technologies Inc. 4.5.13586 Core Profile Context 19.12.2 26.20.15002.61

D6293 may fix this issue, but since I can not reproduce I can not check

Here is the file i created for the screenshot:

Richards file segfaults on my machine, here is the crash log (would this be a seperate task then? Also this is from a different build (hash: affe9e0d925b) then yesterday, but my file still reproduces the issue):

Also here is the system_info to the original report:

Another thing, isn't D6293 on geasepencil-object, or at least merged into greasepencil-object?

@Johannes Mayrhofer (VuiMuich),
Just to be sure. To reproduce the problem is it enough to open one of these files and press F12?


Can't redo.
Operating system: Windows-10-10.0.18941 64 Bits
Graphics card: Radeon (TM) RX 480 Graphics ATI Technologies Inc. 4.5.13586 Core Profile Context 19.50.01.05 26.20.15001.5006

I also can reproduce it on a Surface Pro 4 (see attached system info, can test on the Linux System today evening) with both files @Germano Cavalcante (mano-wii) suggested.
With the Viewportshading set to Material Preview or Rendered I can see the gradients, rendered looks the same as viewport mode Solid

Could it be related to integrated GPU?

So after a rebuild on my manjaro-Linux (hash: bb6dedfc84d8) the file "T74449.blend" no longer causes a segfault, but the issue of this task is still reproducible for me.

ronsn added a subscriber: ronsn.Mar 6 2020, 12:25 AM

I can confirm that on Linux (see specs at the bottom of this comment)!

@Germano Cavalcante (mano-wii) Yes, it is enough to press F12.

T74449.blend (with Viewport Shading set to "Rendered") results in:


and rendered:

T74449_2.blend (with Viewport Shading set to "Rendered") results in:

System Information
Operating system: Linux-5.3.0-40-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1660 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version
Broken: version: 2.83 (sub 7), branch: greasepencil-object, commit date: 2020-03-05 16:30, hash: rB7098b638f2c6
Worked: (optional)

In my morningly build with hash a4bfe6267943 it is fixed.

Thanks, that was quick, even bevor it was flagged as bug 😀

Richard Antalik (ISS) closed this task as Resolved.Mar 6 2020, 8:58 AM
Richard Antalik (ISS) claimed this task.

Ah I see, this report is for greasepencil-object branch, while I tested on master.

Thanks for update, will close this then.