Page MenuHome

Precision issue with large distances
Confirmed, NormalPublic

Description

System Information
Operating system: Win 10
Graphics card: 1080ti{F8399226}

Blender Version
Broken: version: 2.83 (sub 11)
Worked: Never

Short description of error
Unwanted glitches with the use of transparent shader. See picture:


The object with the orange outline is a simple cube with applied scale.

Exact steps for others to reproduce the error

  • Open attached file
  • Go to the Rendered view

The camera should already be selected, change the X coordinate to even higher values in order to make the issue more evident.

Event Timeline

I guess the reason is, that the object is too far from origin (719.817 m, -1112.15 m, 222.678 m). So the z-precision of cycles is not enough at this point.

Peter Baintner (predoe) closed this task as Invalid.Tue, Mar 10, 6:57 PM

Unfortunately scaling this certain scene down does not resolve the issue. Also have a look at the black artefacts on the plane. Those are also coming from missing alpha precision.
Updated version here: https://www.dreisicht.net/share/searchwing/3d/blender/master/master_master_08_bugreport.blend

Ray molenkamp (LazyDodo) reopened this task as Needs Information from User.Tue, Mar 10, 8:37 PM

reopened at request of user

Have not looked at your file, but the stackexchange post is a classic floating point precision issue.

As the integer part of the number gets bigger, you have less storage available to store the fractional part, it's not as much a bug in cycles as just the way computers deal with fractional numbers.

Yes I am aware of precision errors. Just too bad scaling doesn't help. So the only workaround would be to leave the camera in the origin and move everything else?

But still - 700m fur such an error is very unexpected in my opinion.

Ankit (ankitm) renamed this task from Transparent shader glitch to Precision issue with large distances .Thu, Mar 26, 9:57 AM
Ankit (ankitm) changed the task status from Needs Information from User to Needs Triage.
Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Fri, Mar 27, 3:08 PM

The scenario described is too time consuming for us to track down, we require the bug reporter to narrow down the problem.

Normally .blend files can be simplified by removing most objects and disabling settings, until the problem reveals itself more clearly.

Here is a very much simplified version:


Steps to produce this file: create a cylinder, and a cube. Cube gets transparent shader, Move all the objects including the camera 800m from the origin, and you get unwanted refraction.

Germano Cavalcante (mano-wii) changed the task status from Needs Information from User to Confirmed.Fri, Mar 27, 3:50 PM
Germano Cavalcante (mano-wii) updated the task description. (Show Details)

I believe this is a known limitation due to float precision.
@Brecht Van Lommel (brecht), what do you think?