Page MenuHome

copy paste objects from one instance of blender to another instance results in immediate crash of instance being pasted into.
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.17134-SP0 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.83 (sub 6), branch: master, commit date: 2020-03-06 22:46, hash: rBdcdcc2348842
Worked: (optional)

Short description of error
copy paste objects from one instance of blender to another instance results in immediate crash of instance being pasted into.

Exact steps for others to reproduce the error
open below file, select the object, copy it, paste it into another instance of blender. Crash also occurs if you paste it back into the same instance of blender. The issue seems to be material related, because if the material is removed from the object, the crash doesn't happen. Happens with or without the copy attributes addon enabled.

Event Timeline

michael campbell (3di) updated the task description. (Show Details)
michael campbell (3di) updated the task description. (Show Details)

Just tested in today's 2.83 alpha build and the problem is still there.

Just tested in the below build, and the problem is not there.

Ankit Meel (ankitm) closed this task as Resolved.Mar 12 2020, 8:22 AM
Ankit Meel (ankitm) claimed this task.

Thanks for the report!
Please comment or reopen the report if the issue comes back

Hi Ankit, you've closed this in Error, the bug has not been fixed.

Ankit Meel (ankitm) reopened this task as Needs Triage.Mar 12 2020, 12:19 PM
Ankit Meel (ankitm) removed Ankit Meel (ankitm) as the assignee of this task.

Oh misread the date.. bisecting now. Thanks for providing a working build

Just tested in the below build, and the problem is not there.

This is an older build, the bug is still present in current builds.

Bastien Montagne (mont29) triaged this task as High priority.
Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Bug".