Page MenuHome

Cycles and PC frozen on "Updating Images"
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia GTX1080ti, Driver 442.59

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: 375c7dc4caf4, type: Release
build date: 2020-03-12, 15:41:08
Worked: Possibly 2.80

Short description of error

Cycles Issue: I have a typical car model, textured, some modifiers, and is Linked into my main file where I do my rendering. Everything works perfectly in Eevee. As soon as I switch it to Cycles and it goes through its motions, when it comes to “Updating Images” on the top left corner of the viewport the computer becomes unusable, mouse is frozen and the computer is " working". I left it almost 1 hour and nothing happened, so only option to hard shut down the PC.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
Attached is a screenshot before I had to hard restart the PC, Memory working, but went on forever.

Event Timeline

Brecht Van Lommel (brecht) changed the task status from Needs Triage to Needs Information from User.Sat, Mar 14, 12:15 PM

We require a .blend file and exact steps to reproduce the problem using that .blend file.

We require a .blend file and exact steps to reproduce the problem using that .blend file.

Yes I'm working on it to reproduce the issue, unfortunately it is a client's file I cannot release the data.

@Jason Battersby (jbattersby) It looks like you're using a large HDRI which is too large to fit into memory when uncompressed. You can also see that you're getting a lot of disk activity on drive D as it has to use the page file instead of ram. I'd suggest getting a min of 32 gb ram, but you could try changing surface sampling to manual in the world properties tab, and reducing the value to something like 4096 or lower. It would be nice if there were two options here, one for viewport rendering and one for final rendering, or perhaps better still if the lighting only had to update when necessary, it seems to update even when changing material parameters at the moment, which results in a sloooooow experience.

@Jason Battersby (jbattersby) It looks like you're using a large HDRI which is too large to fit into memory when uncompressed. You can also see that you're getting a lot of disk activity on drive D as it has to use the page file instead of ram. I'd suggest getting a min of 32 gb ram, but you could try changing surface sampling to manual in the world properties tab, and reducing the value to something like 4096 or lower. It would be nice if there were two options here, one for viewport rendering and one for final rendering, or perhaps better still if the lighting only had to update when necessary, it seems to update even when changing material parameters at the moment, which results in a sloooooow experience.

I did both that and set the Texture Limit to 4096 and it seems to work now. I guess just too many 6k and 8k textures in the scene, but is there a way to calculate this before, a way of knowing the current size of your scene so this doesn't happen again?

you could use the simplify options to limit textgure size to something small and then run a quick test render with f12, then turn up the settings and re-render until your just within your systems memory capacity. Probably easier to just get more ram though if you can.

You can also use the simplify option to turn on camera culling, that'll ensure you're only using textures that are actually applied to materials that are currently in the camera's field of view. You have to enable this in the simplify settings but also on a per object basis in the culling section of the object properties. Easier to select everything and then hold alt whilst enabling, this way it enables the settings for all objects at once.

Any devs reading this, it would be a good idea to be able to exclude textures from simplification, such as the hdri or textures that will be viewed close up to the camera etc. It's either all or nothing at the moment.

I suppose you could also choose which texture a material uses based on camera distance with a light path node and a greater than math node....although I'm not sure if all textures within a shader are loaded regardless. This would mean you'd have to create duplicate lower quality textures in an external editor, so another idea for the devs would be a resample node perhaps, which could perform that task at render time instead of using simplify.

you could use the simplify options to limit textgure size to something small and then run a quick test render with f12, then turn up the settings and re-render until your just within your systems memory capacity. Probably easier to just get more ram though if you can.


You can also use the simplify option to turn on camera culling, that'll ensure you're only using textures that are actually applied to materials that are currently in the camera's field of view. You have to enable this in the simplify settings but also on a per object basis in the culling section of the object properties. Easier to select everything and then hold alt whilst enabling, this way it enables the settings for all objects at once.
Any devs reading this, it would be a good idea to be able to exclude textures from simplification, such as the hdri or textures that will be viewed close up to the camera etc. It's either all or nothing at the moment.

I'll ive the Camera culling a try, but actually the scene is practically empty, for example I'm rendering now this Mustang so the car's textures should be the high quality ones, so the culling won't cut down on much. It would be great to change the Texture Limit per material, so my car's materials and maybe the Asphalt can be 6k, and the rest much lower especially background objects. As most great substance or scanned textures now are 6k-8k, I always download the highest resolution possible so later on I wont have to manually reload all of the PBR's. What is crazy is Eevee handles the scene like butter, super smooth, but when I want that one detailed shot using cycles it just can't take the amount of textures I guess.

make sure you enable this too, saves more resources when rendering:

make sure you enable this too, saves more resources when rendering:

Lifesaver, thanks!

Evan Wilson (EAW) closed this task as Invalid.Mon, Mar 30, 5:46 AM
Evan Wilson (EAW) claimed this task.

Since this was a memory issue that looks like it was resolved, I'll be closing this.