Page MenuHome

Mantaflow "Replay" cache not working as expected
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX 660M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-12.0.24 355.11.10.50.10.103

Blender Version
Broken: version: 2.83 (sub 11), branch: master, commit date: 2020-03-27 23:12, hash: rB1f949121cd3f

Short description of error
The replay/live preview and modular and final in the mantaflow fluid simulator won’t work for me. I tried deleting the cache folder and making a new one and changing some settings in the mantaflow simulator and changing them back to try to clear the cache but that still didn’t work. Someone on the cg cookie forum said it might be an operating system specific bug.

Exact steps for others to reproduce the error
open blend file and select replay/live preview beside cache type and press play in the timeline or select modular and press bake data or select final and press bake all and press play in the timeline nothing will show up for both of these cache types

Event Timeline

Jesse (BlenderFixS241994) renamed this task from Mantaflow replay/live preview and modular and final won't work. to Mantaflow replay/live preview and modular and final won't work on iMac.Mar 28 2020, 11:53 PM
Jesse (BlenderFixS241994) created this task.

I ran the file from T75201, and there was nothing there at first. Baking did nothing. I created a cube, and applied Quick Fluid to it. I was able to bake that and play it back successfully. I then switched back to your simulation, and baking was working again, I renamed the cache folder before each bake. The blender_debug_output.txt is filled with

Unable to remove directory
Unable to delete file

I think the issue is that you named the cache folder, which seams to cause Blender not delete it or its contents. This isn't noted in the manual as far as I can see. Try renaming the baking cache folder and then re-bake.

I renamed the cache folder to just CACHE in all caps an rebaked the simulator but that still didn't work. Plus I think I rememberer my first attempt of getting mantaflow to work and I think I didn't rename the cache folder then and it still didn't work .

Just a little update I tried mantaflow again in the latest alpha still didn't work.

Sebastián Barschkis (sebbas) changed the task status from Needs Triage to Confirmed.Mar 31 2020, 12:21 PM

Hi, yes I noticed this too. Working on a fix for this now.

Sebastián Barschkis (sebbas) triaged this task as High priority.Apr 7 2020, 2:35 PM

In 7de86ad61fb1 there have been some changes that improve baking with the 'Replay' mode. Those should fix the issues you had over there.

Also, in the file that you attached make sure to Apply -> All Transforms and to Recalculate Normals for the liquid inflow object.

Sebastián Barschkis (sebbas) renamed this task from Mantaflow replay/live preview and modular and final won't work on iMac to Mantaflow "Replay" cache not working as expected.Apr 15 2020, 6:16 PM