Page MenuHome

2.83 Crash on Startup
Closed, InvalidPublic

Description

System Information
Operating system: Darwin-16.7.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX 780M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-10.17.5 355.10.05.45f01

Blender Version
Broken: version: Blender 2.83 Alpha, March 29, 23:40:07 - a103d09df485, macOS 64 bit

Short description of error
App crashs on startup, doesn't matter if I click icon or run it from Terminal.

From previous report I used suggested command with the same result.

./Blender\ 3.app/Contents/MacOS/blender --debug-all >> ~/Downloads/T74922log.txt

Here is requested TXT output with packed Terminal output as well.
Application Support/Blender folder was moved out before running Terminal.

Note as extension: Running one even older iMac it totally freezes OS, I have to use power button to restart. I dont expect so much support for this machine, just as it goes - 2.81 was working, 2.82 partially without eevee or with crash Workench's Shadow ON ... version 2.83 as mentioned. Operating system: Darwin-15.6.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce 9400 OpenGL Engine NVIDIA Corporation 3.3 NVIDIA-10.0.52 310.90.10.05b46

Thank you for help

Event Timeline

ronsn added a subscriber: ronsn.Mar 30 2020, 8:32 PM

@filip mond (vklidu) your graphics card driver seem to be a little bit to old. Can you update your drivers and check again?

The laptop is already at the max Sierra went upto. I don't know if there are any reasons not to update to high Sierra or above.
See if https://download.blender.org/release/ a previous version works for Darwin 16.7.

Running one even older iMac it totally freezes OS, .. Darwin-15.6

Darwin 16/ macOS 10.12 is the min requirement as also said on https://www.blender.org/download/requirements/.

@Ankit jain (Ankit) Thank you for answer. I used 2.82 (or some of first 2.83) and any lower version without any issue under Darwin 16.7 up to now.

To update OS I was already thinking about, but Catalania has so many issues that could cause so many problems in our production, so we decided to do not update since everything was working for now fine. But now ... OK ... I'm trying to update to Mojave, so I will see.

To your requirement's link - Darwin 16 is still mentioned as minimum so I guess I'm still on board with my iMac OS.
(with that one from 2009 Darwin 15.6 - OK its time is over, I got it :)

Ankit Meel (ankitm) changed the task status from Needs Triage to Needs Information from User.Mar 31 2020, 1:56 PM

Let us know if it works on Mojave

filip mond (vklidu) added a comment.EditedMar 31 2020, 8:05 PM

OK, upgrade to Mojave solved the issue to run Blender 2.83, but ...
... now I see what was the main reason I didn't want to upgrade OS - CUDA is not supported. Blender don't see my card anymore, so only CPU rendering from now ...

I got quite schizophrenic info after installation updated driver - "Update Required" even "No newer Driver available". For High Sierra worked installation via CUDA Web Driver, but there is not any for Mojave and higher.

Ankit Meel (ankitm) closed this task as Invalid.Apr 1 2020, 12:42 PM
Ankit Meel (ankitm) claimed this task.

https://forums.developer.nvidia.com/t/cuda-10-and-macos-10-14/65672
It seems 10.13 had better support for cuda. also, 418.163 is the last they had. https://www.nvidia.com/en-us/drivers/cuda/mac-driver-archive/

For High Sierra worked installation via CUDA Web Driver,

If you have a backup, best is to downgrade to High Sierra.

I don't think this can be valid bug on Blender, even Adobe forums have this problem.

This bug seems to be valid until minimum requirement is os 10.12 (as you provided).
I don't want to catch you by word, but to mark this bug as invalid consider adjust minimum to 10.13 as well.

And yes, I also ended up with these two links.
If Im right, downgrade is possible only onto empty disk, that is problem for me now (big data), but that is my personal story.

Thanks for all care you posted here.