Page MenuHome

Grease Pencil doesn't work with sculpt mode
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.83 (I only test this two version 03/04,13/4(the newest) build) commit date: 2020/4/13, hash: rBunknown
Worked:
work with the 2.82a stable
Short description of error

Grease Pencil doesn't work properly in sculpt mode in a already existing file(with the new grease pencil object add),

Exact steps for others to reproduce the error

1.when creating a new file ,selecting with 2d animation , the sculpt mode work well with the first grease pencil
2.but for the next grease pencil object ,it cannot use the sculpt mode(the brush doesn't affect it )
3.worst,you add a grease pencil in a existing file ,you can't even see the size of the sculpt brush

same question 2 weeks ago in community https://blender.community/c/today/BYdbbc/

[Based on the default startup or an attached .blend file (as simple as possible)]

build with 2d

build with empty normal ,then add new object

THANKS!

Event Timeline

Antonio Vazquez (antoniov) changed the task status from Needs Triage to Needs Information from User.Apr 13 2020, 7:17 PM

I cannot reproduce with 2.83. How are you setting the mode? are you using the Outliner? Maybe your object is not in sculpt mode.

I add a short video to show the problem

I can see your sculpt brushes are damaged. I fixed the bug a few days ago in the default template.

try to reset the brushes using the reset all.

Also, be sure to use the last build of 2.83.

EDIT> I have tested with the very last source code compiled by myself just a few minutes ago.

More than a week without reply or activity.
Due to the policy of the tracker closing for until required info/data are provided.

If the problem persists please open a new report with the required information.