Page MenuHome

Blender crashes when you check 'Header > Gizmo > Object Gizmos >Rotate' in Modelling workspace
Closed, ResolvedPublic

Description

System Information
Operating system: macOS 10.13.6 Darwin-17.7.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon HD 6970M OpenGL Engine ATI Technologies Inc. 4.1 ATI-1.68.24

Blender Version
Broken: version: 2.83 (sub 13), branch: master, commit date: 2020-04-14 20:14, hash: rB04f006ea9efe
Short description of error
Like title says, Blender crash when you check in header 'Gizmos >Rotate' in Modelling workspace.

Exact steps for others to reproduce the error

  1. Open Blender and 'Load Factory Settings'
  2. Change to 'Modelling' workspace
  3. Check 'Rotate' in Header > Gizmo > Object Gizmos

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Apr 15 2020, 4:28 PM

Cannot reproduce here

System Information
Operating system: Linux-5.5.13-200.fc31.x86_64-x86_64-with-fedora-31-Thirty_One 64 Bits
Graphics card: GeForce GTX 970M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.64
version: 2.90 (sub 0), branch: master, commit date: 2020-04-15 13:57, hash: rB549b8541873a

@Ankit Meel (ankitm) : can you reproduce this on MacOS?
@Óscar (Oxer) : do you have a chance to upgrade MacOS? or test on another machine?

Óscar (Oxer) renamed this task from Blender crash when you check 'Header > Gizmo > Object Gizmos >Rotate' in Modelling workspace to Blender crashes when you check 'Header > Gizmo > Object Gizmos >Rotate' in Modelling workspace.Apr 15 2020, 4:37 PM

The AMD Radeon HD 6970M has the TeraScale 2 architecture and therefore doesn't fulfill the minimum requirements for Blender 2.8x. GCN first generation or later is required for AMD GPUs. If the issue is related to viewport drawing of gizmos, then this is likely the cause.

Cannot redo, macOS 10.14.6
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) HD Graphics 6000 Intel Inc. 4.1 INTEL-12.10.12
rB51e73e99569d92068d26327aac636fc35db9dcff

Hi, I didn't udgrade the macos and I haven't another machine to test but I installed the new revision Blender 2.83 (sub 13), branch: master, commit date: 2020-04-15 12:03, hash: 54736d505866 and the issue was fixed. 😲

How can I mark as resolved (for the moment)?

Ankit Meel (ankitm) closed this task as Resolved.Apr 16 2020, 6:56 AM
Ankit Meel (ankitm) claimed this task.