Page MenuHome

Broken link in wiki.blender.org
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 432.00

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: rB375c7dc4caf4
Worked: (optional)

Short description of error
When trying to get familiar with blender data, a link is broken

Exact steps for others to reproduce the error
After clicking on link 'Data API' (https://wiki.blender.org/wiki/Dev:2.5/Source/Architecture/DataAPI)
from
RNA (https://wiki.blender.org/wiki/Source/Architecture/RNA)
the result is:
< Dev:2.5/Source

Page Not Found!

. See if it exists in the old Wiki Archive
. Search for this page title mentioned in other pages or related logs
. Create this page

Event Timeline

Ankit (ankitm) added a subscriber: Ankit (ankitm).EditedApr 23 2020, 2:32 PM

. See if it exists in the old Wiki Archive

using this takes you to the correct page though. Click on the "wiki archive".

Ankit (ankitm) closed this task as Invalid.Apr 23 2020, 7:01 PM
Ankit (ankitm) claimed this task.

This is currently the state of every document in the old wiki.

Thanks for the reply.

The reason I reported this was the first line, if I do so:

Note: This is an archived version of the Blender Developer Wiki.
THE CURRENT AND ACTIVE WIKI IS AVAILABLE ON WIKI.BLENDER.ORG

So that's not the case.

Instead of that line, by default there should be a statement, that the link points to the old wiki.

I thank you for your help.

This part of the wiki is currently in migration phase, many design documents can be found in the Wiki Archive.

https://wiki.blender.org/wiki/Source
So yeah, this is expected. And most likely already a todo somewhere.