Page MenuHome

Quick smoke not rendering Cycles and Eevee
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.92

Blender Version
Broken: version: 2.83 (sub 15), branch: master, commit date: 2020-05-04 21:58, hash: rBd8133b3eb99a
unknown

Short description of error
Quick smoke render on frame > 1 of simulation does not render.

Exact steps for others to reproduce the error
new file
create default plane
apply quick smoke
at this point the smoke shows in all views and in a render.
optionally: save blend file.
move to frame 2 - smoke shows in all views, but not on render. Expected: smoke renders as normal
move to frame 1 - again, smoke does not show in render.

This happens with Cycles and Eeevee
if you save the blend file it does not change this behavior. If you bake the simulation, it does not render. If you change the blackbody intensity in the shader, it does not render. If you promise your first born to Satan, it does not render.

I have not figured out how to get it to render at all after this.

UPDATE: smoke will render if you exit and re-open the file.

File:

Event Timeline

Scott VanKirk (svankirk) renamed this task from Quick smoke not rendering to Quick smoke not rendering Cycles and Eevee.May 5 2020, 4:31 AM
Scott VanKirk (svankirk) updated the task description. (Show Details)
Scott VanKirk (svankirk) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.May 5 2020, 10:02 AM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".

Can confirm.

Ah I see, thx, looking into this problem right now!

Since this is a critical bug I pushed a temporary fix. Rendering should work now, the only downside is that changing parameters from flow / effector objects will not invalidate the cache.