Page MenuHome

Cannot make face on spiral.
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 445.87

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional)

Addon Information
Name: Extra Objects (0, 1, 4)
Author: Multiple Authors

Short description of error
when i press F for make face to the spiral, I am answered, [ cannot make segment.]

Exact steps for others to reproduce the error
Create a spiral only in the shape of a drill, then press F.

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Needs Information from User.EditedSat, May 16, 6:31 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

@louismael (colossabot) Are you able to better describe the issue and the steps required to reproduce it? I'm unable to replicate the issue you're describing and it may be because I'm checking in the wrong area of Blender.

Are you also able to test with default settings? Select from the top of Blender "File>Defaults>Load factory settings" then enable the "Extra Objects" addon in the user preferences then attempt to reproduce the issue.

Are you also able to test with Blender 2.83 and 2.90 to see if they fix your issue? https://builder.blender.org/download/

im guessing we talk about curves with the Add Extra addon enabled. normal curvesegments can be connected with F. Wich a spiral created with the addon cant.

@Julian Mohr (Jules) If I understand you correctly, then the steps to reproduce are as follows.

  1. Open user preferences and enable the addon "Add Curve: Extra Objects".
  2. In the 3D viewport, press Shift+A and select "Curve>Curve Spirals>Any option".
  3. If you then try and join any parts of the curve segments with F, it doesn't work.

I have been unable to reproduce this on my system with Blender 2.82a with any of the curves in the "Curves Spirals" section.

Julian Mohr (Jules) added a comment.EditedSat, May 16, 7:57 PM

@Alaska (Alaska) i think i have a clue. you re right. I have tested this with the latest master(2.90)

@louismael (colossabot) please provide more information for this issue and for the next time. according to tracker policy we should have set this to "Needs info from user" and wait till more information is provided.

This is a community afford wich we cant do for every bug.
Please follow the "How to Bug report" https://wiki.blender.org/wiki/Process/Bug_Reports

@Julian Mohr (Jules) In the last part of your video you show of trying to connect two points from the "middle" of the curve. If this is the issue that @louismael (colossabot) is experiencing, then this is not a issue. You're not allowed to join points that are in the "middle" of a curve.

Will leave this report open as "Needs information from user" until @louismael (colossabot) confirms if this is the issue or provides steps to reproduce a different issue they're facing.

Alaska (Alaska) closed this task as Invalid.Sun, May 24, 12:47 AM
Alaska (Alaska) claimed this task.

Closing this report as invalid as there was no response for a week and I and @Julian Mohr (Jules) was only able to replicate the "issue" in a situation where it isn't a issue, but a design choice for Blender.

@louismael (colossabot) If you continue to experience issues and you believe it is a bug, please open a new report. In that report, make sure you include exact steps to reproduce the issue so we can recreate the issue.