Page MenuHome

Blender crashes when closing a window
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10, 64 bit
Graphics card: RTX2070
CPU: Ryzen 3700x

Blender Version
Broken: 2.43 - 2.82, 2.83, 2.9
Worked: 2.42a

At first, blender opens normally. When closing a window that was opened by blender (eg. preferences, render, saving a file...), blender crashes. Once it crashes once, any further opening of blender results in an immediate crash.

Exact steps for others to reproduce the error

  1. Start up blender
  2. Open preferences or render a frame or open any other window
  3. Close window from 2, blender crashes

After doing 1-3 once, when blender is launched, it shows a cmd and crashes

Other info:
I've tested like 15 blender versions to find the one that makes problems, it turns out the newest good one is 2.42a, as 2.43 crashes

On 32-bit versions, the behaviour seems to be the same as when blender is first opened - it opens, but once a window gets closed, it crashes. At least that's how 2.55 behaves, I can't find a 32-bit, modern version.

If I open blender in a sandbox via sandboxie, it runs fine, but I can's use sandboxie very well, so I can't use it to diagnose the issue.

Logs don't seem to have useful info, but I'm attaching the anyway. In 2.82, first one is where it opens and crashes after I close a window and the second one is when it just crashes.

No other programs are crashing this way, so I doubt it has anything to do with hardware.
Is there any diagnostic I can do to help understand the issue? I'd happily run anything, it's running me insane

Event Timeline

Jakub Kraus (JX35) changed the task status from Needs Triage to Needs Information from User.Mon, May 18, 11:23 PM
Jakub Kraus (JX35) created this task.

I believe your GPU is one of the oldest supported by Blender. As a result, it's likely that you will need to run the most up to date drivers for that GPU to avoid issues with Blender. Are you able to update/run a clean install of your GPU drivers? https://www.amd.com/en/support

Huh? Blender is supposed to support cards as old as nvidia's 400 series, I have a card that's like 6 generations newer. The oldest version that crashes this way is 2.43, at that point, this card wasn't even close to release yet. Is there something in the logs that suggests blender thinks it's an old AMD card? Anyway, I tried a clean installation as I've only installed updates normally, didn't help, but thanks for trying

Sorry, I swear the last time I looked your report you were using a GT 210. But that doesn't explain why I thought it was a AMD GPU.
I'm sorry.
I'll leave the management of this task up to someone who's more focused than I am.

  • 2.90 would have a trace file also, in addition to debug log & system info, could you upload that too?
  • Also, retry after moving the Blender folder from C:\Users\jakub\AppData\Roaming\Blender Foundation\Blender\ somewhere else.

4.5.0 NVIDIA 442.19'

  • 445.xx is available.
  • In the logs, this is a new thing for me,

I0518 22:14:12.480294 25176 device_cuda.cpp:2708] Device has compute preemption or is not used for display.

Though I don't know what to do with it.

Not sure about the trace file, never heard of that, where do I find it?
All the other versions I tried were run from D:\Test Blender Versions, but I also now tried moving a fresh 2.82a zip directly to C, didn't help, still crashes.
I've clean installed the latest (studio) drivers as of today, as Alaska asked, but it's the studio driver, so it was 442.92. So to test it out, I've downloaded the latest game ready driver, 445.87, didn't help.

Ankit (ankitm) changed the task status from Needs Information from User to Needs Triage.Tue, May 19, 10:57 AM

Not sure about the trace file, never heard of that, where do I find it?

Oh it seems it is written after an EXCEPTION... occurs; there's no mention of that in the logs.

So, there's two things that I think could help solve it:
The problem is somewhere between 2.42a and 2.43, are there more versions between those points that I could try?
If I run it in sandboxie, it works perfectly fine. If anyone knows how to use sandboxie, could I gradually allow access to more and more to find where the problem is?

And I removed files "blender_system_info 2.83 and 2.90", as they are just duplicates of 2.82, they aren't even generated, it crashes too fast

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Tue, May 19, 2:17 PM

Please open folder C:\Users\jakub\AppData\\Roaming\ and rename or remove (you will loose user preferences) Blender Foundation folder
Then you run blender_factory_startup.cmd from Blender folder and check if that helps.
Also make sure your GPU drivers are up to date.

I can see some reports for crash when closing preferences window on intel GPUs

I will have a look at how to get stack trace and check if there are any useful inormation.

I'd happily run anything, it's running me insane

If above doesn't help I can suggest reinstalling windows (So far I have been 100% successful out of 2 times I recommended this :)

Removing preferences nor running the factory startup helped. I've tried latest GPU drivers, both studio and game optimized, nothing. I don't want to reinstall windows, I still have the option of running blender in a sandbox and manually retrieve the files from sandboxie, but that's a pain. Tomorrow I'll try to build code between 2.42a and 2.43, but I've never built anything from source, so I'm not giving it much hope. I've run Procdump and got a ~600mb memory dump file, but I can't read it, would that be useful?

I will recommend looking at this guide https://wiki.blender.org/wiki/Building_Blender/Windows
It is very easy to follow.

Also I would recommend building latest master, and when crash occurs it will show you where and what went wrong (usually). If you can send us this screenshot, we may be able to identify the problem.

I am not sure if mem dump would help, I have never needed to go that low level, so I have no experience here.

I built it from source and suddenly, the problem is gone, with all versions. It's really weird, sometimes it just fixes itself like that, but it always comes back. I'll write here once it begins again, thanks everyone for help

Richard Antalik (ISS) closed this task as Invalid.Mon, May 25, 12:10 AM
Richard Antalik (ISS) claimed this task.

sometimes it just fixes itself like that, but it always comes back. I'll write here once it begins again, thanks everyone for help

Do you mean, that this happened to you before?

In any case, thanks for update, I will close this report until problem reappears or more info is provided.