Page MenuHome

Cache option disappears for Domain type-Flow
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 Home
Graphics card: AMD Vega 8 & RX560X

Blender Version
Broken:2.82
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (2.77)

Short description of error
When type-Domain(quick effect) cache option is present but when I change type-Flow the baking option disappears and the smoke does not appears while playing
Exact steps for others to reproduce the error
Create an object and add quick smoke and there is bake option in Cache menu.But change type from Domain to Flow cache menu disappears and while playing the animation smoke or fire does not appears!
Based on the default startup

Event Timeline

Alaska (Alaska) closed this task as Invalid.Fri, May 22, 1:21 PM
Alaska (Alaska) claimed this task.
Alaska (Alaska) added a subscriber: Alaska (Alaska).

The reason why the cache menu isn't there when the type is set to "Flow" is because a cache can only be built for domains. Baking a cache for a "Flow" object is impossible without a domain object and in it's current implementation, Blender designed so you generate a cache for all objects in a domain rather than individual objects which would be the case if you could bake the cache for individual flow objects.

As for why your smoke simulation isn't working when you convert your domain to a flow object, that's because you no longer have a domain meaning no smoke simulations can occur.

As for why 2.77 had a cache option of flow objects, I would take a guess that it was probably a oversight. However, if baking the cache for individual objects in a domain was possible back then, it may not be possible now as the smoke and fluid simulation system drastically changed between 2.81 and 2.82. Hopefully the Blender manual can provide some useful information: https://docs.blender.org/manual/en/latest/physics/index.html

Note: Sometimes keyboard shortcuts and menu placements in the Blender manual may be incorrect. I am currently in the process of updating the manual to fix these kinds of issues. So if you find a issue with the manual, note it's probably there because I haven't worked on that part of the manual yet. Or, it requires the attention of someone with more knowledge in that area.

I tried domain + flow objects but still it didn't didnt show in animation!

Are you able to provide a copy of your scene?