Page MenuHome

Negative numeric transforms are broken
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.48

Blender Version
Broken: version: 2.83 (sub 17), branch: master, commit date: 2020-05-25 17:35, hash: rB39aa122a0e6d
Worked: 2.82a

Short description of error
Transforms (move, rotate, scale) done through numeric input no longer work when adding a minus sign after inputting the value.

Exact steps for others to reproduce the error
Select the default cube.
Press G, Z, -1
The cube will move down -1 on the Z axis.
Press G, Z 1, -. The cube will not move down -1 on the Z axis.

In 2.82a, this works, and is very handy because you don't have to worry about which scale, move or rotation axis (positive or negative) is correct.
For example, if you want to rotate an object on the X axis by 45 degrees, you can simply type R X 45. If you find that the rotation was in the wrong direction, you can type the "-" key afterward and it fixes the rotation.
The way it works now is that you get an error.

Here's the error in 2.83beta

Here's the correct output in 2.82a

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Needs Information from User.EditedMay 28 2020, 5:36 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

I am unable to reproduce the issue you're describing.

It looks to me like you're in "advanced numerical input mode". This is activated by pressing * while entering a value or can be enabled by default in the preferences.
To find the setting in the user preferences follow these steps:

  1. Select from the top of Blender Edit -> Preferences.
  2. Select the Input tab.
  3. Change the Default to Advanced Numeric Input to the setting you prefer. Off should give you the results you want and it should be off by default.

If that fails, try loading factory defaults to see if that helps. Select form the top of Blender File -> Defaults -> Load Factory Settings.

If loading factory defaults fixes the issue, then open preferences Edit -> Preferences and click the Save preferences button. Now when ever you open Blender, it should work as expected.
Note: You will lose any previously set preferences (E.G. GPU to render with, themes, custom keymaps, etc).

Ah! Thank you! The "Advanced Numerical Input Mode" was the issue. I'm not sure how it got turned on but disabling it fixed the problem.

Cheers!

Alaska (Alaska) closed this task as Invalid.May 28 2020, 8:32 PM
Alaska (Alaska) claimed this task.