Page MenuHome

In orthogonal view, XYZ axis overlay toggle doesn't work with axis aligned views
Confirmed, LowPublicKNOWN ISSUE

Description

Blender Version
Broken: 2.8x

Short description of error
In orthogonal view, XYZ axis overlay toggle doesn't work

Exact steps for others to reproduce the error
press numpad 1
open the overlays panel
toggle xyz axis, they won't hide.

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Confirmed.May 31 2020, 8:26 AM
Jeroen Bakker (jbakker) changed the task status from Confirmed to Needs Information from User.Jun 2 2020, 8:14 AM

Unable to reproduce on master

Please note that this ticket is missing information for example what version isn't working, what version is working or did it never worked. What does the user see. 2.8x means every blender 2.8x release?

Axis visible:

Axis hidden:

I am also unable to reproduce in Blender 2.82a, 2.83, and 2.90. Why did I mark this as confirmed when I couldn't reproduce it? Nevermind.

However, @Jeroen Bakker (jbakker) , I'm unable to get the X,Y,Z grid to toggle in a specific view (E.G. Front view (Numberpad 1), top view (Numberpad 7)). Not sure if this is intended behavior or even if this is what @Gilberto Rodrigues (gilberto_rodrigues) is reporting about.

@Alaska (Alaska), please elaborate.

Does the Grid option not hide it for you? The grid option is specific for the orthographic grid (see documentation and help text when hovering over the item). The X, Y, Z are Axis options and does not influence the display of grid or floor.

Does the Grid option not hide it for you?

The Grid option hides it for me. It was the X, Y, and Z options that I was talking about.

The grid option is specific for the orthographic grid (see documentation and help text when hovering over the item). The X, Y, Z are Axis options and does not influence the display of grid or floor.

There's nothing in the tooltip of the grid check box that implies that the red, green, and blue axis lines for X, Y, Z are part of the grid and aren't separately controlled by the X, Y, Z buttons.

The manual also doesn't mention this. : https://docs.blender.org/manual/en/dev/editors/3dview/display/overlays.html

Looks like this might be more of a documentation task than a Blender bug.

Video just so we're on the same page:

Oops, I forgot to mention to go into front/side/top views, etc. That's what I meant to report, sorry!
I don't like idea of this behavior being documented like this without a meaningful design reason. People need the grid without the axes, or the axes without the grid. The toggles are there, so they should work in any view. Or at least make the blue of the toggle faded like when the wireframe overlay is disabled, to tell the user when the toggle is useless, but again, i'd preffer having it more useful. Maybe make it a known issue, idk.

Campbell Barton (campbellbarton) renamed this task from In orthogonal view, XYZ axis overlay toggle doesn't work to In orthogonal view, XYZ axis overlay toggle doesn't work with axis aligned views.Jun 11 2020, 8:49 AM
Campbell Barton (campbellbarton) changed the task status from Needs Information from User to Confirmed.
Campbell Barton (campbellbarton) triaged this task as Low priority.

Marking as confirmed, although we might want to keep it working this way.

Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Known Issue".Oct 14 2020, 10:06 AM