Page MenuHome

Viewport wireframe is not showing Subdivision Modifier mesh.
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: RTX 2070SU

Blender Version
Broken: v2.83
Worked: v2.82.7

Short description of error
Previewing wireframe (z > wireframe) not showing wireframe of the subdivision modifier - need to apply to show.

Exact steps for others to reproduce the error

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Confirmed.Jun 6 2020, 2:45 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

Can confirm but having difficulty bisecting to find the cause to see if this is an intentional change.

Alaska (Alaska) closed this task as Invalid.Jun 6 2020, 4:14 AM
Alaska (Alaska) claimed this task.

Upon further investigation with help from another user, this appears to be an intentional change. This is due to the fact that the Optimal display option for the sub-division surface modifier is enabled by default in 2.83.

Here is the commit rB09b8cdb25e45. The issue here, as I see it, is that this change isn’t mentioned in the 2.83 release notes. @Sergey Sharybin (sergey) could you add this change to the wiki please?

@Evan Wilson (EAW), good point. Added brief statement about this.