Page MenuHome

Persistent images improves performance in different aspects but cannot use for animations
Closed, InvalidPublic

Description

System Information
TR2970WX 24c, 32G DDR4, Aorus X399 Gaming 7
Operating system:
LINUX
Graphics card:
1070GTX

Blender Version
Blender 2.83 Full Release via blender.org

Short description of error
Persistent images improves performance in different aspects but cannot use for animations, (request to limit quantity of frames to keep in buffers?)

Exact steps for others to reproduce the error

I am experiencing issues with persistent images on Linux.
Seeing slowdowns when not using it, and huge issues using it, animations..
I have tried to see if this was linked to specific Linux version and tried the duplicate my issues in each of the following,
Ubuntu
Pop OS
Manjaro

Moving to Linux I have experienced a hefty performance increase in CPU render, (from 46 seconds to 40 seconds) on my Threadripper

Sadly the improvements found on Linux don't really work unless using persistent images.

Main issue I notice.
1, (this doesn't occur in windows 10) but it does here on Linux.
Disable of persistent images,
Rendering in GPU only, or combined (GPU/CPU)
I experience a small delay at the end of the render on the last render tile sometimes it will be maybe with 10 tiles left.. but where it should complete in say 0.5 seconds.. it delays to take upto 4-5 seconds,

it seems to be computing something and takes approx 2-4 seconds seconds to respond. this is adding to the time for renders and slowing things.

2,
if I enable persistent images, the performance is increased, the compiling (just before render tiles start) time is hugely quicker and the 2-4 seconds delay at the end of render is doesn't happen anymore, so the scene renders in some cases upto 10-12 seconds on faster

3,
when persistent images is enabled blender becomes hugely unstable rendering animations... (when compared to windows, windows seems to go further before becoming unstable)
The first 1-2 frames with my project file render fine. But as it continues.. it looks to make blender unresponsive and take upto 60-90 seconds to complete while making blender look completely unresponsive.
Without question blender will fail and disappear from the screen.

It's important to use a blend file with large file size.. example 300-400MB and the textures are fairly large,
I thought that using simplify to limit texture sizes might improve, but it doesn't help

Replicate the issue:
the following blender demo file works well to demonstrate the issue at hand.
https://cloud.blender.org/p/gallery/5dd6d7044441651fa3decb56
this is the 2.81 junk shop demo

simply enable one 3d view to render as material, and hit render as animation (ctrl-F12)

Perhaps a fix might be to limit the amount of data it can store.. such as a limited amount of frames to keep in buffers

Event Timeline

Richard Antalik (ISS) closed this task as Invalid.Wed, Jun 24, 8:16 AM
Richard Antalik (ISS) claimed this task.

Thanks for the report, but the issue reported here is a request for modified/improved behavior and not a bug in current behavior. Closing as this bug tracker is only for bugs and errors.

For user requests and feedback, please use other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests

For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

This was more of a report of the huge cycles problem that has existed throughout a few late versions of blender..

2.79, 2.80, 2.81, 2.82, 2.83 and 2.90 alpha

When if this issue going to be taken care of?

The usage scenarios for persistent images is a huge feature of blender. That boggles the mind that it's still an option in the program which basically entirely breaks blender..

:(

shaun (toxsickcity) renamed this task from Persistent images improves performance in different aspects but cannot use for animations, (request to limit quantity of frames to keep in buffers?) to Persistent images improves performance in different aspects but cannot use for animations.Sun, Jun 28, 9:59 AM
shaun (toxsickcity) updated the task description. (Show Details)