Page MenuHome

Blender crushes when collection selecting shortcuts are pressed.
Closed, ResolvedPublic

Description

System Information
Operating system: windows 10 1903
Graphics card: GTX 1080ti

Blender Version
Broken: 2.83.1 stable
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
When editing object directly belongs to the scene collection, switch to object mode and press number keys to fast pick a collection. If the related collection is not checked, blender instantly crushes without any error message.
It doesn't happen all the time, but quite often. I think maybe it has something to do with the editing did to the object.
Sometimes I get a error message like this:


In this project file, I changed the name of collection 1 to “album".
I tested opening another project file and press 1, blender still searches for the collection named "album". Is it possible that the part of collection numbering and naming function doesn't automaticly link to the current project?

Exact steps for others to reproduce the error


Create an object and move it to scene collection. Uncheck all collections then edit the object, I think some duplicate and seperate operations will get more chance to crush blender. Finally switch back to object mode and press 1.

Event Timeline

NXSK (NXSK) updated the task description. (Show Details)Jun 28 2020, 11:18 AM
NXSK (NXSK) updated the task description. (Show Details)
NXSK (NXSK) updated the task description. (Show Details)Jun 28 2020, 11:45 AM
NXSK (NXSK) updated the task description. (Show Details)

Hi @NXSK (NXSK),
Sorry for the late reply, I only saw this recently.
You seem to be reporting two different bugs here, but I can't reproduce either of them (even using 2.83.1).
Could you see if the bugs are still present in 2.90?
I develop on Linux, so this could be a Windows only bug, so I'll see if I can reproduce it on Windows in a bit.
Thanks.

Ryan Inch (Imaginer) changed the task status from Needs Triage to Needs Information from User.Sep 29 2020, 8:15 AM

@NXSK (NXSK),
Okay, I've tried to reproduce it with blender 2.83.1 on windows 8, but I can't reproduce either of the bugs you mention.

Can you please check one of the daily builds and see if the bugs are still there?
Thanks.

Hi @NXSK (NXSK),
Sorry for the late reply, I only saw this recently.
You seem to be reporting two different bugs here, but I can't reproduce either of them (even using 2.83.1).
Could you see if the bugs are still present in 2.90?
I develop on Linux, so this could be a Windows only bug, so I'll see if I can reproduce it on Windows in a bit.
Thanks.

Thank you for replying and sorry for my later reply. It's been busy these days........
I'm now using 2.90.1. It seems to be fine with 2.90.1. And I will give a notice on this.

Okay, great! I look forward to your conclusion.

Ryan Inch (Imaginer) closed this task as Resolved.Nov 5 2020, 7:48 PM

Since there hasn't been anything further, I'm going to assume everything is working now and close this as resolved.